]> code.ossystems Code Review - openembedded-core.git/commitdiff
upgrade gcc to 4.5.0 for mips architecture
authorDongxiao Xu <dongxiao.xu@intel.com>
Sun, 19 Sep 2010 14:29:09 +0000 (22:29 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Wed, 22 Sep 2010 16:52:41 +0000 (09:52 -0700)
Fix the out of memory when building webkit-gtk with gcc-4.5.0

The new feature added after 4.3.3
"http://www.pubbs.net/200909/gcc/94048-patch-add-support-for-rmipsjalr.html"
will cause cc1plus eat up all the system memory when build webkit-gtk.
The function mips_get_pic_call_symbol keeps on recursively calling itself.
Disable this feature to walk aside the bug.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/conf/distro/include/poky-default.inc
meta/recipes-devtools/gcc/gcc-4.5.0.inc
meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch [new file with mode: 0644]
meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.0.bb
meta/recipes-devtools/gcc/gcc-cross_4.5.0.bb
meta/recipes-devtools/gcc/gcc-runtime_4.5.0.bb
meta/recipes-devtools/gcc/gcc_4.5.0.bb

index 0dabeec27cc30a5382b753e17c1b42262a0aa570..1e1a04c1f2cf8772aa06d8c16951b1d14bd4bc66 100644 (file)
@@ -16,7 +16,6 @@ PREFERRED_PROVIDER_virtual/${SDK_PREFIX}libc-for-gcc-nativesdk ?= "${POKYLIBC}-n
 
 
 GCCVERSION ?= "4.5.0"
-GCCVERSION_mips ?= "4.3.3"
 SDKGCCVERSION ?= "4.5.0"
 BINUVERSION ?= "2.20.1"
 GLIBCVERSION ?= "2.10.1"
index 6ca2f98bc88f5629645bc90b30b89ce483013314..6da8ddaa538d428f98a478aac0a7fa5d2ebe3cb6 100644 (file)
@@ -47,6 +47,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
            file://gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \
           file://64bithack.patch \
           file://optional_libstdc.patch \
+          file://disable_relax_pic_calls_flag.patch \
          "
        
 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch b/meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch
new file mode 100644 (file)
index 0000000..b1d5a1a
--- /dev/null
@@ -0,0 +1,44 @@
+GCC: disable MASK_RELAX_PIC_CALLS bit
+
+The new feature added after 4.3.3
+"http://www.pubbs.net/200909/gcc/94048-patch-add-support-for-rmipsjalr.html"
+will cause cc1plus eat up all the system memory when build webkit-gtk.
+The function mips_get_pic_call_symbol keeps on recursively calling itself.
+Disable this feature to walk aside the bug.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN gcc-4.5.0-orig/gcc/configure gcc-4.5.0/gcc/configure
+--- gcc-4.5.0-orig/gcc/configure       2010-09-17 23:30:21.000000000 +0800
++++ gcc-4.5.0/gcc/configure    2010-09-19 18:21:28.000000000 +0800
+@@ -23945,13 +23945,6 @@
+         rm -f conftest.*
+       fi
+     fi
+-    if test $gcc_cv_as_ld_jalr_reloc = yes; then
+-      if test x$target_cpu_default = x; then
+-        target_cpu_default=MASK_RELAX_PIC_CALLS
+-      else
+-        target_cpu_default="($target_cpu_default)|MASK_RELAX_PIC_CALLS"
+-      fi
+-    fi
+     { $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_as_ld_jalr_reloc" >&5
+ $as_echo "$gcc_cv_as_ld_jalr_reloc" >&6; }
+diff -ruN gcc-4.5.0-orig/gcc/configure.ac gcc-4.5.0/gcc/configure.ac
+--- gcc-4.5.0-orig/gcc/configure.ac    2010-09-17 23:30:21.000000000 +0800
++++ gcc-4.5.0/gcc/configure.ac 2010-09-19 18:21:11.000000000 +0800
+@@ -3467,13 +3467,6 @@
+         rm -f conftest.*
+       fi
+     fi
+-    if test $gcc_cv_as_ld_jalr_reloc = yes; then
+-      if test x$target_cpu_default = x; then
+-        target_cpu_default=MASK_RELAX_PIC_CALLS
+-      else
+-        target_cpu_default="($target_cpu_default)|MASK_RELAX_PIC_CALLS"
+-      fi
+-    fi
+     AC_MSG_RESULT($gcc_cv_as_ld_jalr_reloc)
+     AC_CACHE_CHECK([linker for .eh_frame personality relaxation],
index e1a8e970d0c9a6d66ec9a01efa0d2301ddc78a88..a9f79b650959d653ca675ce8517966f008650095 100644 (file)
@@ -5,7 +5,7 @@ require gcc-cross-canadian.inc
 require gcc-configure-sdk.inc
 require gcc-package-sdk.inc
 
-PR = "r7"
+PR = "r8"
 
 DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
 RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
index 2246663594b3745cf94e01ba72dabc31333f0126..d3a068e1f6631ffd8754f385ab2efae0ae8119e6 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 2231c4269e59cb623c4d660b1a5f77b932a230dd..79ce466a29b610554f6589cd3337dd3d082c49d2 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
 
 require gcc-${PV}.inc
 require gcc-configure-runtime.inc
index 45bbb01e4029befbd1cb0b3daab404a852da057f..a42fb39764ab882d6da7c989426def6a2493dc67 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc