]> code.ossystems Code Review - openembedded-core.git/commitdiff
task-core-nfs/image.bbclass: Fix some libc overrides
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2011 13:52:27 +0000 (14:52 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2011 13:52:27 +0000 (14:52 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/image.bbclass
meta/recipes-core/tasks/task-core-nfs.bb

index 346dd5edc335637b54413edb5cd7e164c89b2c46..2469442d70899b06d2e3136c9c248c048b325ba7 100644 (file)
@@ -24,8 +24,7 @@ PID = "${@os.getpid()}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 LDCONFIGDEPEND ?= "ldconfig-native:do_populate_sysroot"
-LDCONFIGDEPEND_linux-uclibc = ""
-LDCONFIGDEPEND_linux-uclibceabi = ""
+LDCONFIGDEPEND_libc-uclibc = ""
 
 do_rootfs[depends] += "makedevs-native:do_populate_sysroot virtual/fakeroot-native:do_populate_sysroot ${LDCONFIGDEPEND}"
 do_rootfs[depends] += "virtual/update-alternatives-native:do_populate_sysroot update-rc.d-native:do_populate_sysroot"
index 20e042bd205dada301d665de432b4b7235afe258..5859fad071934e3142123a23b20a821f85e2672b 100644 (file)
@@ -22,5 +22,5 @@ RDEPENDS_task-core-nfs-server = "\
 # rpcinfo can be useful but only with glibc images
 GLIBC_DEPENDENCIES = "glibc-utils"
 
-RRECOMMENDS_task-core-nfs-server_append_linux = " ${GLIBC_DEPENDENCIES}"
-RRECOMMENDS_task-core-nfs-server_append_linux-gnueabi = " ${GLIBC_DEPENDENCIES}"
+RRECOMMENDS_task-core-nfs-server_append_libc-glibc = " ${GLIBC_DEPENDENCIES}"
+