]> code.ossystems Code Review - openembedded-core.git/commitdiff
sudo: Avoid post install scripts
authorMark Hatle <mark.hatle@windriver.com>
Wed, 9 Nov 2011 23:04:08 +0000 (17:04 -0600)
committerSaul Wold <sgw@linux.intel.com>
Fri, 11 Nov 2011 08:33:50 +0000 (00:33 -0800)
The post install script was removed, and the install_append updated
to ensure the permissions are set correctly.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-extended/sudo/sudo.inc
meta/recipes-extended/sudo/sudo_1.8.3.bb

index 72a7c167cd659ee130720731ce85824ad5c75442..83dd209afae7d281e030545ef73b133fd6c0604a 100644 (file)
@@ -29,11 +29,3 @@ do_install_prepend (){
        mkdir -p ${D}/${localstatedir}/lib
 }
 
-pkg_postinst_${PN} () {
-       if [ "x$D" != "x" ]; then
-               exit 1
-       fi
-
-       chmod 4111 /usr/bin/sudo
-       chmod 0440 /etc/sudoers
-}
index 0ac08511535b1d8c5ca6ec9fc00f9d55fc5066a7..99fe5b91e76461c26f71a4970af4394452938edc 100644 (file)
@@ -1,6 +1,6 @@
 require sudo.inc
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-${PV}.tar.gz \
            file://libtool.patch \
@@ -23,4 +23,7 @@ do_install_append () {
                        break
                fi
        done
+
+       chmod 4111 $D/usr/bin/sudo
+       chmod 0440 $D/etc/sudoers
 }