]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc-2.12: Fix build on powerpc/603e
authorKhem Raj <raj.khem@gmail.com>
Thu, 22 Sep 2011 15:57:26 +0000 (08:57 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Sep 2011 20:00:22 +0000 (21:00 +0100)
We pass --with-cpu to eglibc now. Which breaks
the configure for cpus that it does not support
We add support for ppc603e which gets 2.12
building for qemuppc.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc_2.12.bb

diff --git a/meta/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch b/meta/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch
new file mode 100644 (file)
index 0000000..5c90e5b
--- /dev/null
@@ -0,0 +1,26 @@
+We now pass --with-cpu option to eglibc this ends up with configure errors if we do
+not pass a cpu which eglibc has support for in sysdeps
+
+| checking sysdep dirs... configure: error: The 603e subspecies of powerpc is not supported.
+| + bbfatal 'oe_runconf failed'
+| + echo 'ERROR: oe_runconf failed'
+
+We fix this by adding the 603e sub directories with Implies to generic
+powerpc to overcome this error
+
+Upstream-Status: Inappropriate [OE config related]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libc/ports/sysdeps/powerpc/powerpc32/603e/Implies
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ libc/ports/sysdeps/powerpc/powerpc32/603e/Implies  2011-09-17 19:18:57.593292084 -0700
+@@ -0,0 +1 @@
++powerpc/powerpc32
+Index: libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/Implies
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/Implies  2011-09-17 19:17:48.613292100 -0700
+@@ -0,0 +1 @@
++powerpc/powerpc32
index 0fbd070497f0b270b4ab4a148660a17340dc18b6..42202196da6c0f4760003a697b16143a56968bcd 100644 (file)
@@ -1,7 +1,7 @@
 require eglibc.inc
 
 DEPENDS += "gperf-native"
-PR = "r26"
+PR = "r27"
 
 SRCREV = "14158"
 
@@ -12,6 +12,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http
            file://shorten-build-commands.patch \
            file://mips-rld-map-check.patch \
            file://armv4-eabi-compile-fix.patch \
+           file://ppc-enable-603e-cpu.patch \
            file://etc/ld.so.conf \
            file://generate-supported.mk \
          "