]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernelshark: fix recompile error
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 7 Aug 2014 03:05:22 +0000 (20:05 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Aug 2014 09:46:58 +0000 (10:46 +0100)
Fixed:
make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `parse-events.o'.  Stop.
make: *** Waiting for unfinished jobs....
ERROR: oe_runmake failed

This happens when upgrade gcc from 4.9.0 to 4.9.1, and the
.parse-events.d isn't regenerated when recompile, the content of it are:

[snip]
parse-events.o: /path/to/sysroot/4.9.0/include/stddef.h
[snip]

And Makefile includes the .parse-events.d file if it exists, so there
would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't
exist.

Remove .*.d (a few .d files, its Makefile uses this wildcard) will fix
the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/trace-cmd/kernelshark_1.2.bb

index 9af91c9599a95e180e04f9eba3f155d611029150..99de97bcc7123a249c1966340c2e9d0d464267bd 100644 (file)
@@ -13,6 +13,11 @@ SRC_URI_append = "file://kernelshark-fix-syntax-error-of-shell.patch"
 
 EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'prefix=${prefix}' gui"
 
+do_compile_prepend() {
+    # Make sure the recompile is OK
+    rm -f ${B}/.*.d
+}
+
 do_install() {
        oe_runmake CC="${CC}" AR="${AR}" prefix="${prefix}" DESTDIR="${D}" install_gui
        rm ${D}${bindir}/trace-cmd