]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnss-mdns: add $D to postinst paths
authorIlya Yanok <yanok@emcraft.com>
Wed, 27 Apr 2011 22:56:58 +0000 (00:56 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 May 2011 11:09:22 +0000 (12:09 +0100)
Post installation script can be called during image creation so paths
should relative to $D.

Signed-off-by: Ilya Yanok <yanok@emcraft.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb

index b04b20abee2764a2220a5b7f496831dffa00938f..651a2407b82c2ad3af46377374df7314f3628da7 100644 (file)
@@ -26,9 +26,9 @@ EXTRA_OECONF = "--libdir=/lib --disable-lynx --enable-avahi"
 
 # TODO: pattern based configuration update
 pkg_postinst_${PN} () {
-       cat /etc/nsswitch.conf | grep "hosts:\s*files dns$" > /dev/null && {
-               cat /etc/nsswitch.conf | sed 's/hosts:\s*files dns/& mdns4/' > /tmp/nsswitch.conf
-               mv /tmp/nsswitch.conf /etc/nsswitch.conf
+       cat $D/etc/nsswitch.conf | grep "hosts:\s*files dns$" > /dev/null && {
+               cat $D/etc/nsswitch.conf | sed 's/hosts:\s*files dns/& mdns4/' > /tmp/nsswitch.conf
+               mv /tmp/nsswitch.conf $D/etc/nsswitch.conf
        }
 }