]> code.ossystems Code Review - openembedded-core.git/commitdiff
logrotate: Add new logrotate package
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Wed, 1 Sep 2010 02:29:03 +0000 (10:29 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 2 Sep 2010 22:19:34 +0000 (15:19 -0700)
logrotate allows for the rotation, compression and removal of system log file

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/recipes-extended/logrotate/logrotate_3.7.9.bb [new file with mode: 0644]

diff --git a/meta/recipes-extended/logrotate/logrotate_3.7.9.bb b/meta/recipes-extended/logrotate/logrotate_3.7.9.bb
new file mode 100644 (file)
index 0000000..f657d78
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "Rotates, compresses, removes and mails system log files"
+SECTION = "console/utils"
+PRIORITY = "required"
+HOMEPAGE = "https://fedorahosted.org/releases/l/o/logrotate"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS="coreutils"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
+
+SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.gz"
+
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+do_install(){
+    oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
+}
+
+do_install_append(){
+    mkdir -p ${D}${sysconfdir}/logrotate.d
+    mkdir -p ${D}${sysconfdir}/cron.daily
+    mkdir -p ${D}${localstatedir}/lib
+    install -p -m 644 examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
+    install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
+    touch ${D}${localstatedir}/lib/logrotate.status
+}