]> code.ossystems Code Review - openembedded-core.git/commitdiff
python, python-native: fix PARALLEL_MAKEINST failure
authorChristopher Larson <chris_larson@mentor.com>
Mon, 25 Nov 2013 17:25:24 +0000 (17:25 +0000)
committerRobert Yang <liezhi.yang@windriver.com>
Sun, 26 Jan 2014 06:08:14 +0000 (14:08 +0800)
When using make -j with the 'install' target, it's possible for altbininstall
(which normally creates BINDIR) and libainstall (which doesn't, though it
installs python-config there) to race, resulting in a failure due to
attempting to install python-config into a nonexistent BINDIR. Ensure it also
exists in the libainstall target.

(From OE-Core master rev: 54da47f3ddc1c009594744793060ffd09db3ad11)

Signed-off-by: Christopher Larson <kergoth@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-devtools/python/python-native_2.7.3.bb
meta/recipes-devtools/python/python/parallel-makeinst-create-bindir.patch [new file with mode: 0644]
meta/recipes-devtools/python/python_2.7.3.bb

index ef891b246c771178a0bc66e8a19bb680fd4d4c4d..6b87a16d41954b998b4c129cba63146d66f28a88 100644 (file)
@@ -16,6 +16,7 @@ SRC_URI += "\
            file://multilib.patch \
            file://add-md5module-support.patch \
            file://builddir.patch \
+           file://parallel-makeinst-create-bindir.patch \
            "
 S = "${WORKDIR}/Python-${PV}"
 
diff --git a/meta/recipes-devtools/python/python/parallel-makeinst-create-bindir.patch b/meta/recipes-devtools/python/python/parallel-makeinst-create-bindir.patch
new file mode 100644 (file)
index 0000000..951cb46
--- /dev/null
@@ -0,0 +1,19 @@
+When using make -j with the 'install' target, it's possible for altbininstall
+(which normally creates BINDIR) and libainstall (which doesn't, though it
+installs python-config there) to race, resulting in a failure due to
+attempting to install python-config into a nonexistent BINDIR. Ensure it also
+exists in the libainstall target.
+
+Upstream-Status: Pending
+
+--- Python-2.7.3.orig/Makefile.pre.in
++++ Python-2.7.3/Makefile.pre.in
+@@ -1008,7 +1008,7 @@ LIBPL=           $(LIBP)/config
+ LIBPC=                $(LIBDIR)/pkgconfig
+
+ libainstall:  all python-config
+-      @for i in $(LIBDIR) $(LIBP) $(LIBPL) $(LIBPC); \
++      @for i in $(LIBDIR) $(LIBP) $(LIBPL) $(LIBPC) $(BINDIR); \
+       do \
+               if test ! -d $(DESTDIR)$$i; then \
+                       echo "Creating directory $$i"; \
index fb7d1c9355a205c801224567e31cb0dea3471ede..50c7f9b5d2c28f141d2ec49f9e25dac9c18b219e 100644 (file)
@@ -32,6 +32,7 @@ SRC_URI += "\
   file://run-ptest \
   file://CVE-2013-4073_py27.patch \
   file://pypirc-secure.patch \
+  file://parallel-makeinst-create-bindir.patch \
 "
 
 S = "${WORKDIR}/Python-${PV}"