]> code.ossystems Code Review - openembedded-core.git/commitdiff
bluez-libs: upgraded to 3.17 from OE, disabled CUPS support
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 7 Sep 2007 09:02:14 +0000 (09:02 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 7 Sep 2007 09:02:14 +0000 (09:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2712 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/bluez/bluez-libs.inc [new file with mode: 0644]
meta/packages/bluez/bluez-libs_3.17.bb [new file with mode: 0644]

diff --git a/meta/packages/bluez/bluez-libs.inc b/meta/packages/bluez/bluez-libs.inc
new file mode 100644 (file)
index 0000000..2f33120
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+        oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+        install -d ${STAGING_INCDIR}/bluetooth/
+        for f in ${HEADERS}
+        do
+               install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+        done
+}
diff --git a/meta/packages/bluez/bluez-libs_3.17.bb b/meta/packages/bluez/bluez-libs_3.17.bb
new file mode 100644 (file)
index 0000000..6ddf62a
--- /dev/null
@@ -0,0 +1 @@
+require bluez-libs.inc