]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: Further missing files tweaks
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 26 Aug 2009 19:50:43 +0000 (20:50 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 26 Aug 2009 19:50:43 +0000 (20:50 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
meta/packages/opkg-utils/opkg-utils_svn.bb

index 3eb2c9349a665788630d1226781b89c669535a60..bafc2f6a1ca5824ac27104bf42d59f6a04c36ea1 100644 (file)
@@ -1,14 +1,7 @@
-If we're building an image and some package rebuilds while this is happening
-some package can be removed/added to the ipk deploy directory. The image will
-not depend on this package so we can safely ignore these cases rather than 
-error out.
-
-RP - 26/8/09
-
 Index: opkg-utils/opkg-make-index
 ===================================================================
 --- opkg-utils.orig/opkg-make-index    2009-08-26 17:21:26.000000000 +0100
-+++ opkg-utils/opkg-make-index 2009-08-26 17:24:05.000000000 +0100
++++ opkg-utils/opkg-make-index 2009-08-26 20:49:52.000000000 +0100
 @@ -96,6 +96,7 @@
  files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
  files.sort()
@@ -22,8 +15,26 @@ Index: opkg-utils/opkg-make-index
            if opt_s:
                 print filename
 +  except OSError:
-+      sys.stderr.write("Package %s disappeared on us!\n" % (filename,))
++      sys.stderr.write("Package %s disappeared on us!\n" % (filename))
 +      continue
  
  pkgsStampsFile = open(stamplist_filename, "w")
  for f in pkgsStamps.keys():
+@@ -148,6 +152,7 @@
+ names = packages.packages.keys()
+ names.sort()
+ for name in names:
++  try:
+      pkg = packages.packages[name]
+      if locales_dir and pkg.depends:
+          depends = string.split(pkg.depends, ',')
+@@ -165,6 +170,9 @@
+      if (verbose):
+           sys.stderr.write("Writing info for package %s\n" % (pkg.package,))
+      print pkg
++  except OSError:
++      sys.stderr.write("Package %s disappeared on us!\n" % (name))
++      continue
+ if packages_filename:
+      sys.stdout.close()
+      sys.stdout = old_stdout
index 53b208db1491dfe9cc6130acf73a51dea920e52a..a141505710fc403659ab2cdd8cc17e34249c5212 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "optional"
 LICENSE = "GPL"
 RDEPENDS = "python"
 RDEPENDS_virtclass-native = ""
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
            file://index-ignore-filenotfound.patch;patch=1"