]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-nose: don't install as an Egg
authorRoss Burton <ross.burton@intel.com>
Tue, 14 Jan 2014 11:10:49 +0000 (11:10 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jan 2014 17:59:24 +0000 (17:59 +0000)
Nose is installed as an Egg by default which we don't want, so change the
inherit to setuptools from distutils to disable the eggification.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-nose_1.2.1.bb

index a59f77c6a9d04fb4d1c439b9f54612ccc380c6c7..f55461d0478cbb5bd1456ecdb05e5dbf41831aef 100644 (file)
@@ -11,6 +11,6 @@ SRC_URI[sha256sum] = "2171e9202d118d302d5db1decb52dd862b79e2a626ca19653a6914574a
 
 S = "${WORKDIR}/nose-${PV}"
 
-inherit distutils
+inherit setuptools
 
 BBCLASSEXTEND = "native nativesdk"