]> code.ossystems Code Review - openembedded-core.git/commitdiff
gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 16 May 2019 11:45:01 +0000 (12:45 +0100)
committerArmin Kuster <akuster808@gmail.com>
Sun, 2 Jun 2019 17:25:22 +0000 (10:25 -0700)
This solves ptest runtime errors where make was missing causing the ptests
to fail.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
[Fixup for warrior context]
[Dropped ptest fixes for pkg w/o ptests in warrior]
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/flex/flex_2.6.0.bb
meta/recipes-extended/gzip/gzip_1.10.bb
meta/recipes-extended/parted/parted_3.2.bb
meta/recipes-extended/slang/slang_2.3.2.bb
meta/recipes-support/attr/attr.inc

index b89b7515b56c17dae2287a8a18368dac08ad94ec..b477cd8c7f22b94829de11df2a3cfaf76b4ef305 100644 (file)
@@ -48,7 +48,7 @@ PACKAGES =+ "${PN}-libfl"
 FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
 
 RDEPENDS_${PN} += "m4"
-RDEPENDS_${PN}-ptest += "bash gawk"
+RDEPENDS_${PN}-ptest += "bash gawk make"
 
 do_compile_ptest() {
        oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
index 75de97063102d397150802c455af5b017f049556..6a5b2459e6d95eaeda16354cafb1bed0792be549 100644 (file)
@@ -12,6 +12,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
 
 PROVIDES_append_class-native = " gzip-replacement-native"
 
+RDEPENDS_${PN}-ptest += "make"
+
 BBCLASSEXTEND = "native"
 
 inherit ptest
index 6189fd2246543aeec0fd60dd8dc8516b123b1939..ceac52892db967670c367d829d4299a0aa5c3680 100644 (file)
@@ -47,7 +47,7 @@ do_install_ptest() {
        sed -e 's| ../parted||' -i $t/tests/*.sh
 }
 
-RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3"
+RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make"
 
 inherit update-alternatives
 
index e53c4321b9aac97826259f9abd20ec4e287d94d3..e329310937961a4625cec0b831e4c4b0312f9b8e 100644 (file)
@@ -75,6 +75,8 @@ do_install_ptest() {
 
 FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
 
+RDEPENDS_${PN}-ptest += "make"
+
 PARALLEL_MAKE = ""
 PARALLEL_MAKEINST = ""
 
index cfa38a7196496485b14d16ad1f170902408a744b..1a29eb339e75c956bd43f1559745b0e5ccf9f7e9 100644 (file)
@@ -41,6 +41,6 @@ do_install_ptest() {
        sed -e 's|; @echo|; echo|' -i ${D}${PTEST_PATH}/test/Makefile
 }
 
-RDEPENDS_${PN}-ptest = "attr coreutils perl-module-filehandle perl-module-getopt-std perl-module-posix"
+RDEPENDS_${PN}-ptest = "attr coreutils perl-module-filehandle perl-module-getopt-std perl-module-posix make"
 
 BBCLASSEXTEND = "native nativesdk"