]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: Drop staging functions. If failures occur we just need to improve do_install
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 19 Nov 2009 11:50:58 +0000 (11:50 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 19 Nov 2009 11:50:58 +0000 (11:50 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/python/python-dbus_0.83.0.bb
meta/packages/python/python-iniparse-native_0.2.3.bb
meta/packages/python/python-pycairo_1.4.0.bb
meta/packages/python/python-pygobject-native_2.16.0.bb
meta/packages/python/python-pygobject_2.16.0.bb
meta/packages/python/python-pygtk_2.10.4.bb
meta/packages/python/python-pyrex-native_0.9.8.5.bb
meta/packages/python/python-pyrex_0.9.8.5.bb
meta/packages/python/python-scons-native_0.97.bb
meta/packages/python/python-urlgrabber-native_3.1.0.bb
meta/packages/python/yum-metadata-parser-native_1.1.2.bb

index 275e60e329d951ad35b592396ef18612358d7b2b..d35b2808feadf49e26d11494ee5bdf293c6d52d4 100644 (file)
@@ -16,10 +16,6 @@ export HOST_SYS
 export STAGING_LIBDIR
 export STAGING_INCDIR
 
-do_stage() {
-       autotools_stage_all
-}
-
 RDEPENDS = "python-io python-logging python-stringold python-threading python-xml"
 
 FILES_${PN}-dev += "${libdir}/pkgconfig 
index c2d633c5f2ed0ab0ac01fada6fb1f0a96ca95bc1..bb841fed100aa0ca3f14870a0488ffa4551f9a58 100644 (file)
@@ -2,9 +2,5 @@ require python-iniparse_${PV}.bb
 inherit native
 DEPENDS = "python-native"
 RDEPENDS = ""
+NATIVE_INSTALL_WORKS = "1"
 
-do_stage() {
-       BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-       STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \    
-        ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
-}
index 9bb2fdfcd8ffdf8a0a737c83f9706f87ee7ddcfa..82487755875e2c4f4ed86fb277131a55aba5bcc0 100644 (file)
@@ -10,10 +10,3 @@ S = "${WORKDIR}/pycairo-${PV}"
 
 inherit distutils pkgconfig
 
-do_stage() {
-       install -d ${STAGING_INCDIR}
-       install -m 0644 cairo/pycairo.h ${STAGING_INCDIR}
-
-    # nasty pkgconfig fix necessary here
-    sed -i -e s,${STAGING_DIR_NATIVE},, pycairo.pc
-}
index a1c733334ccd2058e94f00cabcc65300ef7bd8b7..f5b9cb338cca96f62001759daebe0a7f78423636 100644 (file)
@@ -7,12 +7,14 @@ PARALLEL_MAKE = ""
 
 inherit native
 
+NATIVE_INSTALL_WORKS = "1"
+
 SRC_URI = "\
   ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
 #  file://python-path.patch;patch=1 \
 "
 
-do_stage_append() {
-       install -d ${STAGING_BINDIR}
-       install -m 0755 gobject/generate-constants ${STAGING_BINDIR}/gobject-generate-constants
+do_install_append() {
+       install -d ${D}${bindir}
+       install -m 0755 gobject/generate-constants ${D}${bindir}/gobject-generate-constants
 }
index 773ffdff492c4605385e09abe4c0215e6abf9070..de07ec762c8f1757c5c860c99d8d72e306fff421 100644 (file)
@@ -22,14 +22,6 @@ export HOST_SYS
 export STAGING_INCDIR
 export STAGING_LIBDIR
 
-do_stage() {
-       autotools_stage_all
-       install -d ${STAGING_LIBDIR}/../share/pygobject/
-       cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
-       install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
-       cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
-}
-
 PACKAGES += "${PN}-lib"
 
 RDEPENDS_${PN} += "python-textutils"
index 6b26f59ad804378aede369a7e2ac2fc9e9f5a091..c37f64e51da4bc7de732532f195a49792c8327f8 100644 (file)
@@ -49,13 +49,3 @@ FILES_${PN}-dev += "\
   ${bindir}/pygtk-* \
   ${datadir}/pygtk/2.0"
 
-do_stage() {
-       autotools_stage_includes
-       sed -i s:/usr/share:${STAGING_DATADIR}: codegen/pygtk-codegen-2.0
-       install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/
-       install -d ${STAGING_DATADIR}/pygtk/2.0/codegen
-       install -d ${STAGING_DATADIR}/pygtk/2.0/defs/
-       cp -pPr codegen/*.py* ${STAGING_DATADIR}/pygtk/2.0/codegen/
-       cp -pPr *.defs ${STAGING_DATADIR}/pygtk/2.0/defs/
-       cp -pPr gtk/*.defs ${STAGING_DATADIR}/pygtk/2.0/defs/
-}
index 44052120400e8de979d7d7705300a56c507c7a6b..7912355449b4606997e30e14ee7bf6b3f3871a65 100644 (file)
@@ -3,8 +3,4 @@ inherit native
 DEPENDS = "python-native"
 RDEPENDS = ""
 
-do_stage() {
-       BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-       STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
-        ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
-}
+NATIVE_INSTALL_WORKS = "1"
index 03468a052289ed7582efcca6da142df53e8c4fa8..7523e112791bbbc34982904718795c8740c1c305 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "devel/python"
 PRIORITY = "optional"
 LICENSE = "GPL"
 SRCNAME = "Pyrex"
-PR = "ml1"
+PR = "ml2"
 
 SRC_URI = "\
   http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
index 45eeee117a3b1c21b3459ea14479ba797457a0f4..915cbabd903cb61324e4c44888f5fc3e70fb5d36 100644 (file)
@@ -3,14 +3,5 @@ inherit native
 DEPENDS = "python-native"
 RDEPENDS = ""
 
-do_stage() {
-        STAGING_LIBDIR=${STAGING_LIBDIR} \
-        STAGING_INCDIR=${STAGING_INCDIR} \
-        BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-        ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_LIBDIR}/.. --install-data=${STAGING_DATADIR} || \
-        oefatal "python setup.py install execution failed."
-}
+NATIVE_INSTALL_WORKS = "1"
 
-do_install() {
-       :
-}
index 5e43ca2d87ad460c324ca4e6bd27016169c67c7f..353fd653074e92933124b8032cb87c112f662fae 100644 (file)
@@ -3,8 +3,5 @@ inherit native
 DEPENDS = "python-native"
 RDEPENDS = ""
 
-do_stage() {
-       BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-       STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
-        ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
-}
+NATIVE_INSTALL_WORKS = "1"
+
index 8a43ec462dbc8d64f78d845d704bea276b9c710b..3fff85afa3522060abc458ffc374d63defc82177 100644 (file)
@@ -5,8 +5,4 @@ RDEPENDS = ""
 
 #BUILD_CFLAGS += "-I${STAGING_LIBDIR}/glib-2.0"
 
-do_stage() {
-       BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-       STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
-        ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
-}
+NATIVE_INSTALL_WORKS = "1"