]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl/tcl: fix /usr/share/man/man3/Thread.3 conflicts
authorHongxu Jia <hongxu.jia@windriver.com>
Sat, 21 Dec 2019 06:19:35 +0000 (14:19 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Dec 2019 23:38:12 +0000 (23:38 +0000)
While installing perl-doc and tcl-doc to image, there is a file conflicts
at do_rootfs
...
|file /usr/share/man/man3/Thread.3 conflicts between attempted installs of
perl-doc-5.30.1-r0.core2_64 and tcl-doc-8.6.10-r0.core2_64
...

Use update-alternatives to fix

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl_5.30.1.bb
meta/recipes-devtools/tcltk/tcl_8.6.10.bb

index 9b1f1af0729524ef4060556d9b6d6f73e96ddb17..6e0b2007fb79b27030add3c0f6ec4fec71d796bf 100644 (file)
@@ -32,7 +32,7 @@ SRC_URI[perl-cross.sha256sum] = "edce0b0c2f725e2db3f203d6d8e9f3f7161256f5d159055
 
 S = "${WORKDIR}/perl-${PV}"
 
-inherit upstream-version-is-even
+inherit upstream-version-is-even update-alternatives
 
 DEPENDS += "zlib virtual/crypt"
 
@@ -240,6 +240,10 @@ FILES_${PN}-module-cpan += "${libdir}/perl5/${PV}/CPAN \
                           "
 FILES_${PN}-module-unicore += "${libdir}/perl5/${PV}/unicore"
 
+ALTERNATIVE_PRIORITY = "40"
+ALTERNATIVE_${PN}-doc = "Thread.3"
+ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3"
+
 # Create a perl-modules package recommending all the other perl
 # packages (actually the non modules packages and not created too)
 ALLOW_EMPTY_${PN}-modules = "1"
index 284f20e27ae25ba5f210f5f20332d1c7353a60af..aedd96b02122435ab48937ada37c327ec5ca68d6 100644 (file)
@@ -34,7 +34,7 @@ S = "${WORKDIR}/${BPN}${PV}/unix"
 
 VER = "${PV}"
 
-inherit autotools ptest binconfig
+inherit autotools ptest binconfig update-alternatives
 
 EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}"
 
@@ -65,6 +65,9 @@ FILES_tcl-lib = "${libdir}/libtcl8.6.so.*"
 FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8"
 FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh"
 
+ALTERNATIVE_${PN}-doc = "Thread.3"
+ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3"
+
 # isn't getting picked up by shlibs code
 RDEPENDS_${PN} += "tcl-lib"
 RDEPENDS_${PN}_class-native = ""