]> code.ossystems Code Review - openembedded-core.git/commitdiff
libzypp: upgrade to newer git version
authorQing He <qing.he@intel.com>
Tue, 11 Jan 2011 08:40:04 +0000 (16:40 +0800)
committerSaul Wold <sgw@linux.intel.com>
Sun, 30 Jan 2011 20:09:52 +0000 (12:09 -0800)
this works with rpm 5.4.0

Signed-off-by: Qing He <qing.he@intel.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch [new file with mode: 0644]
meta/recipes-extended/libzypp/libzypp_git.bb

index 804667e10d6b14c40d01d96327959ad8e3b343ee..de3a1e386b077e57c3777f0bc2a01c5052921edf 100644 (file)
@@ -76,7 +76,7 @@ SRCREV_pn-libxcb-nativesdk ??= "625ed596cae6dd8175aeb6cb6f26784928042f22"
 SRCREV_pn-libxext ??= "d1f3bc77a48c8e42771579e3fdf3370b35d3209d"
 SRCREV_pn-libxext-nativesdk ??= "d1f3bc77a48c8e42771579e3fdf3370b35d3209d"
 SRCREV_pn-libxi ??= "d0326fe8cdbb08d4f52d79fd3fd4e1b2a0951d5e"
-SRCREV_pn-libzypp = "4494797d5b0369365b1af63921de45b197ead64f"
+SRCREV_pn-libzypp = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
 SRCREV_pn-linux-firmware ??= "40c0f950be7040614dc45df54e25e54d00e3b73b"
 SRCREV_pn-linux-openmoko ??= "5ccaca2adb1c37b5955a4733f68ae08a755e3d78"
 SRCREV_pn-linux-omap ??= "58cf2f1425abfd3a449f9fe985e48be2d2555022"
diff --git a/meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch b/meta/recipes-extended/libzypp/libzypp/rpm5-no-rpmdbinit.patch
new file mode 100644 (file)
index 0000000..f15bb68
--- /dev/null
@@ -0,0 +1,25 @@
+diff --git a/zypp/target/rpm/librpmDb.cc b/zypp/target/rpm/librpmDb.cc
+index 1689fbb..4999cd9 100644
+--- a/zypp/target/rpm/librpmDb.cc
++++ b/zypp/target/rpm/librpmDb.cc
+@@ -60,20 +60,6 @@ public:
+     const char * root = ( _root == "/" ? NULL : _root.asString().c_str() );
+     int          perms = 0644;
+-    // check whether to create a new db
+-    PathInfo master( _root + _dbPath + "Packages" );
+-    if ( ! master.isFile() )
+-    {
+-      // init database
+-      int res = ::rpmdbInit( root, perms );
+-      if ( res )
+-      {
+-        ERR << "rpmdbInit error(" << res << "): " << *this << endl;
+-        _error = shared_ptr<RpmInitException>(new RpmInitException(_root, _dbPath));
+-        ZYPP_THROW(*_error);
+-      }
+-    }
+-
+     // open database
+     int res = ::rpmdbOpen( root, &_db, (readonly_r ? O_RDONLY : O_RDWR ), perms );
+     if ( res || !_db )
index c65ae46b0501cc7d1734c3daa12e45e05bbbe191..b9110eb09e172267bf0a950b7bafce76b1ae06eb 100644 (file)
@@ -17,7 +17,9 @@ PR = "r6"
 
 SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
            file://no-doc.patch \
-           file://rpm5.patch "
+           file://rpm5.patch \
+           file://rpm5-no-rpmdbinit.patch \
+          "
 
 SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"