]> code.ossystems Code Review - openembedded-core.git/commitdiff
bootchart2: Add missing python3-math dependency
authorMarek Vasut <marex@denx.de>
Sun, 16 Jan 2022 03:42:46 +0000 (04:42 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Jan 2022 11:48:17 +0000 (11:48 +0000)
Without this dependency, generating the bootchart may fail with:
"
ModuleNotFoundError: No module named 'random'
"

Signed-off-by: Marek Vasut <marex@denx.de>
Cc: Mingli Yu <mingli.yu@windriver.com>
Cc: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb

index 87f7631ddc68b6609444ac31aa2145fe0a753ad2..f0349dacf00f1929ef489826a240a94d1dc0dd8e 100644 (file)
@@ -151,7 +151,7 @@ do_install () {
 
 PACKAGES =+ "pybootchartgui"
 FILES:pybootchartgui += "${PYTHON_SITEPACKAGES_DIR}/pybootchartgui ${bindir}/pybootchartgui"
-RDEPENDS:pybootchartgui = "python3-pycairo python3-compression python3-image python3-shell python3-compression python3-codecs"
+RDEPENDS:pybootchartgui = "python3-pycairo python3-compression python3-image python3-math python3-shell python3-compression python3-codecs"
 RDEPENDS:${PN}:class-target += "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}"
 RDEPENDS:${PN}:class-target += "lsb-release"
 DEPENDS:append:class-native = " python3-pycairo-native"