]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: fix python-audit RDEPENDS
authorBruce Ashfield <bruce.ashfield@gmail.com>
Mon, 3 May 2021 12:54:31 +0000 (08:54 -0400)
committerSteve Sakoman <steve@sakoman.com>
Fri, 7 May 2021 15:21:23 +0000 (05:21 -1000)
When doing the perf python3 conversion, the audit-python RDEPENDS
was caught up in the regex replacement and was incorrectly changed.

The audit recipe continues to produce a package called audit-python
and it is that package we should have as a RDEPENDS.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 7eccb9c0c2ea00685451c44cb8faa96c4a2272fd)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-kernel/perf/perf.bb

index 578b871e9e434963caff59e9850753684a9a106e..b6f50583f7950e077b19b21f27e5b160cf72dc40 100644 (file)
@@ -265,7 +265,7 @@ PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
 
 RDEPENDS_${PN} += "elfutils bash"
 RDEPENDS_${PN}-archive =+ "bash"
-RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python3', '', d)}"
+RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
 RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
 RDEPENDS_${PN}-tests =+ "python3"