]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: Do not use outline-atomics on aarch64
authorKhem Raj <raj.khem@gmail.com>
Thu, 14 May 2020 17:30:09 +0000 (10:30 -0700)
committerSteve Sakoman <steve@sakoman.com>
Wed, 17 Jun 2020 03:06:39 +0000 (17:06 -1000)
This avoids the __getauxval undefined reference error seen with gcc10 on
doing static linking with -nodefaultlibs, which is uncommon usecase
anyway, disabling outline-atomics is not a huge deal for OE in terms of
performance as we already use -mcpu which is tuned enough to the SOC the
code is being generated for

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 3952738d083b888e5b898ed3d63a0ed9a4dd3712)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/valgrind/valgrind_3.15.0.bb

index 7954437a1a76dc90da27e064b469d28194ccd093..25837e4b44b5ce8f9473be758340e2a0510dff4d 100644 (file)
@@ -74,6 +74,8 @@ EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEIN
 # valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
 EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
 
+CFLAGS_append_aarch64 = " -mno-outline-atomics "
+
 EXTRA_OEMAKE = "-w"
 
 CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"