]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers-yocto: use common linux-yocto routines
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 18 Nov 2010 21:20:48 +0000 (16:20 -0500)
committerSaul Wold <Saul.Wold@intel.com>
Sat, 11 Dec 2010 06:01:37 +0000 (22:01 -0800)
Modify linux-libc-headers-yocto to use the common linux-yocto
routines, so headers exported to userspace will track the
branches in the yocto kernel git repository.

This commit also switches supported boards to prefer the
yocto libc headers.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb

index 3e3c1fa9ba1565caa7bb8fefc34df9fb170a4186..05152339584d08813cf1599a0fada55ea53e912e 100644 (file)
@@ -1,4 +1,7 @@
 require linux-libc-headers.inc
+include recipes-kernel/linux/linux-yocto.inc
+
+B = "${S}"
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS += "unifdef-native"
@@ -8,7 +11,9 @@ PR = "r1"
 
 SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;fullclone=1"
 
-S = "${WORKDIR}/linux"
+SRCREV_FORMAT = "meta_machine"
+SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
+           git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
 
 set_arch() {
        case ${TARGET_ARCH} in
@@ -26,19 +31,11 @@ do_configure() {
        oe_runmake allnoconfig ARCH=$ARCH
 }
 
-do_kernel_checkout() {
-       if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then
-               rm -rf ${S}
-               mkdir ${S}
-               mv ${WORKDIR}/.git ${S}
-               mv ${S}/.git/refs/remotes/origin/* ${S}/.git/refs/heads
-               rmdir ${S}/.git/refs/remotes/origin
-       fi
-       cd ${S}
-       git checkout -f standard
+do_kernel_configme() {
 }
 
-addtask kernel_checkout before do_patch after do_unpack
+do_patch () {
+}
 
 do_compile () {
 }