]> code.ossystems Code Review - openembedded-core.git/commitdiff
shadow: Fix rpm failed dependencies when install
authorZhai Edwin <edwin.zhai@intel.com>
Tue, 30 Aug 2011 08:05:01 +0000 (16:05 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 18:58:23 +0000 (19:58 +0100)
There are some links become invalid after rename, so that failed dependencies
detected when install rpm package. This commit update links to resolve it.

[YOCTO #1158] got fixed.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/shadow/shadow_4.1.4.3.bb

index 728b8e5b204d8002c0c0e19cdb1e77bf4f65b4f3..5bc4a6183eb6fcd295683737b675ee816696b12e 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
 
 DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_PLUGINS}', '', d)}"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
            file://login_defs_pam.sed \
@@ -97,6 +97,11 @@ do_install_append() {
        mv ${D}${sbindir}/vipw ${D}${base_sbindir}/vipw.${PN}
        mv ${D}${bindir}/login ${D}${base_bindir}/login.${PN}
 
+       # Handle link properly after rename, otherwise missing files would
+       # lead rpm failed dependencies.
+       ln -sf vipw.${PN} ${D}${base_sbindir}/vigr.${PN}
+       ln -sf newgrp.${PN} ${D}${bindir}/sg
+
        # Ensure we add a suitable securetty file to the package that has
        # most common embedded TTYs defined.
        if [ ! -z "${SERIAL_CONSOLE}" ]; then