]> code.ossystems Code Review - openembedded-core.git/commitdiff
Rename gcc-native3 -> gcc3-native for consistency and update sanity.bbclass to accoun...
authorRichard Purdie <richard@openedhand.com>
Tue, 5 Feb 2008 17:27:12 +0000 (17:27 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 5 Feb 2008 17:27:12 +0000 (17:27 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3670 311d38ba-8fff-0310-9ca6-ca027cbcb966

build/conf/local.conf.sample
meta/classes/sanity.bbclass
meta/packages/gcc/gcc-native_3.4.4.bb
meta/packages/qemu/qemu-native.inc

index 149cd81abf18fc4aecf1017e842afd174fe29e9f..122a6f720a72d7632e4ee891355ed30d18e1310c 100644 (file)
@@ -94,7 +94,7 @@ TMPDIR = "${OEROOT}/build/tmp"
 
 # Comment this out if you don't have a 3.x gcc version available and wish
 # poky to build one for you. The 3.x gcc is required to build qemu-native.
-ASSUME_PROVIDED += "gcc-native3"
+ASSUME_PROVIDED += "gcc3-native"
 
 # Uncomment these two if you want BitBake to build images useful for debugging.
 # DEBUG_BUILD = "1"
index 85a38ba285a7b9797aa8d5fc5651448f7b2fa356..46bc7c66b62e2b66ebfeb9cff5fae1417be67033 100644 (file)
@@ -85,12 +85,15 @@ def check_sanity(e):
        required_utilities = "patch help2man diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum"
 
        # qemu-native needs gcc 3.x
-       if "qemu-native" not in assume_provided:
+       if "qemu-native" not in assume_provided and "gcc3-native" in assume_provided:
                gcc_version = commands.getoutput("${BUILD_PREFIX}gcc --version | head -n 1 | cut -f 3 -d ' '")
 
                if not check_gcc3(e.data) and gcc_version[0] != '3':
+                       messages = messages + "gcc3-native was in ASSUME_PROVIDED but the gcc-3.x binary can't be found in PATH"
                        missing = missing + "gcc-3.x (needed for qemu-native),"
-       else:
+
+       if "qemu-native" in assume_provided:
+               messages = messages + "qemu-native was in ASSUME_PROVIDED but the QEMU binaries can't be found in PATH"
                required_utilities = required_utilities + " qemu-arm"
 
        for util in required_utilities.split():
index eb1fb5716e71452c709e3cb7491d32b7eea01294..d70a4f54648f2faae6d1cf319498e609ef875777 100644 (file)
@@ -1,3 +1,3 @@
 require gcc_${PV}.bb
 require gcc-native.inc
-PROVIDES += "gcc-native3"
\ No newline at end of file
+PROVIDES += "gcc3-native"
index db405c940d4a8ce2ee04db27ae51476bbf038b91..8a25383c59758d287fa3f59de190a8be3430a22b 100644 (file)
@@ -1,5 +1,5 @@
 inherit native
 
-DEPENDS = "zlib-native gcc-native3"
+DEPENDS = "zlib-native gcc3-native"
 
 require qemu-gcc3-check.inc