]> code.ossystems Code Review - openembedded-core.git/commitdiff
run-postinsts: switch to opkg
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 31 Mar 2008 18:34:38 +0000 (18:34 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 31 Mar 2008 18:34:38 +0000 (18:34 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4152 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/run-postinsts/run-postinsts
meta/packages/meta/run-postinsts/run-postinsts.awk
meta/packages/meta/run-postinsts_1.0.bb

index 334a39b78b8e220a864bd5bebf71da44ee8e88a8..cb24a623fd701a9df77b466999ac4502c2d1a45d 100755 (executable)
@@ -5,7 +5,7 @@
 # Author: Richard Purdie <rpurdie@openedhand.com>
 #
 
-PKGSYSTEM=/usr/lib/ipkg
+PKGSYSTEM=/usr/lib/opkg
 STAMP=$PKGSYSTEM/postinsts-done
 STATFILE=$PKGSYSTEM/status
 STATFILE2=$PKGSYSTEM/status2
index 1532577b6e4b2ff0b87cd22ad17c78732221e803..46ee8df9a4d3bf6f3a1ae11827262b3fdd9d3cff 100644 (file)
@@ -14,7 +14,7 @@ BEGIN {
 }
 /Status:.*unpacked.*/ {
   print "Configuring: " package > "/dev/stderr"
-  ret = system("/usr/lib/ipkg/info/" package ".postinst 1>&2")
+  ret = system("/usr/lib/opkg/info/" package ".postinst 1>&2")
   if (ret == 0)
     $0 = gensub("unpacked", "installed", 1)
   else
index b095adc9095120b31677fc4975982ce590e2831d..bf132f51f3bac3b3a0e943266ef68fefe86b33b8 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Run postinstall scripts on device using awk"
 SECTION = "devel"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "file://run-postinsts file://run-postinsts.awk"