]> code.ossystems Code Review - openembedded-core.git/commitdiff
libevent: fix the multilib header conflict
authorZhixiong Chi <zhixiong.chi@windriver.com>
Mon, 13 Aug 2018 07:04:23 +0000 (00:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Aug 2018 10:36:22 +0000 (11:36 +0100)
Error: Transaction check error:
  file /usr/include/event2/event-config.h conflicts between attempted installs of libevent-dev-2.1.8-r0.skylake_64 and lib32-libevent-dev-2.1.8-r0.x86

The conflict is the size macro definition between 32bit and 64bit
such as:
< #define EVENT__SIZEOF_LONG 8
> #define EVENT__SIZEOF_LONG 4
< #define EVENT__SIZEOF_PTHREAD_T 8
> #define EVENT__SIZEOF_PTHREAD_T 4

Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libevent/libevent_2.1.8.bb

index 83ce4644cf572f9d7786e0e79cf8da9ef7a3aac4..0f91e05a6c9db7ecebab7730d598a152c7a9ffd1 100644 (file)
@@ -28,12 +28,16 @@ inherit autotools
 # Needed for Debian packaging
 LEAD_SONAME = "libevent-2.1.so"
 
-inherit ptest
+inherit ptest multilib_header
 
 DEPENDS = "zlib"
 
 BBCLASSEXTEND = "native nativesdk"
 
+do_install_append() {
+        oe_multilib_header event2/event-config.h
+}
+
 do_install_ptest() {
        install -d ${D}${PTEST_PATH}/test
        for file in ${B}/test/.libs/regress ${B}/test/.libs/test*