]> code.ossystems Code Review - openembedded-core.git/commitdiff
Correct js jsautocfg.h and install jsproto.tbl
authorDarren Hart <dvhart@linux.intel.com>
Mon, 20 Sep 2010 23:15:05 +0000 (16:15 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 21 Sep 2010 22:40:17 +0000 (23:40 +0100)
I'm adding mediatomb packages and ran into a couple build issues with js.

The first complained that jsapi.h wasn't found/usable. This turned out to
be because jsautocfg.h was including "../conf.h" instead of "conf.h" as
they are installed in the same directory in the sysroot. I believe the correct
fix for this would involve the configure.ac script which is used to generate
the jsautocfg.h header file we store in the recipe. Commit
f25d26de776f9927e1d2c92f031085a9b9323087 (js: fix configure) added conf.h,
Qing can you comment here?

The second failure is due to jsproto.tbl not being installed but being
referenced by another header file.

This patch corrects the jsautocfg.h header directly and adds the jsproto.tbl
to the do_install() recipe function.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
CC: Qing He <qing.he@intel.com>
meta/recipes-support/js/files/jsautocfg.h
meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb

index 16e38bf8d61c9500dc01c6cb0d2ae1c870a25a12..295e4919bbeb97d65c8242d4e3eda3cc1e09dcf5 100644 (file)
@@ -3,7 +3,7 @@
 
 /* AUTOMATICALLY GENERATED - DO NOT EDIT */
 
-#include "../conf.h"
+#include "conf.h"
 
 #ifdef WORDS_BIGENDIAN
 # undef  IS_LITTLE_ENDIAN
index 97cba90d03c01565798d9aee140bffd0e11d153b..3632eb93e723b2dbdd7db804c42e0f296651ace4 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 # the package is licensed under either of the following
 LICENSE = "MPL1.1 | GPLv2+ | LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://jsapi.c;beginline=4;endline=39;md5=347c6bbf4fb4547de1fa5ad830030063"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/js/js-1.8.0-rc1.tar.gz \
            file://link_with_gcc.patch \
@@ -40,6 +40,7 @@ do_install() {
        install -d ${D}${includedir}/js
        oe_libinstall -so -C Linux_All_OPT.OBJ libjs ${D}${libdir}
        install -m 0644 ${S}/*.h ${D}${includedir}/js
+       install -m 0644 ${S}/jsproto.tbl ${D}${includedir}/js
 }
 
 FILES_${PN} = "${libdir}/lib*.so"