]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Support musl-x32 build
authorsweeaun <swee.aun.khor@intel.com>
Wed, 5 Jul 2017 23:56:37 +0000 (16:56 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 8 Jul 2017 12:33:59 +0000 (13:33 +0100)
Existing musl fixups in perl recipe doesn't cover linux-muslx32.
This is fixed to support musl-x32 build.

Signed-off-by: sweeaun <swee.aun.khor@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/perl/perl_5.24.1.bb

index b0ceb84912a2f0fce2bc5adea1f0c803e7c2b93f..95d96940052200d8b5ccaa9f21bf7983b3af0217 100644 (file)
@@ -125,7 +125,7 @@ do_configure() {
         done
 
         # Fixups for musl
-        if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then
+        if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" -o "${TARGET_OS}" = "linux-muslx32" ]; then
                 sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \
                        -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
                        -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \