]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnu-config: Only apply path transformations in the non-native/non-nativesdk case
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Dec 2011 12:42:27 +0000 (12:42 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Dec 2011 12:45:53 +0000 (12:45 +0000)
The BUILD_ARCH != TARGET_ARCH check isn't a safe one to detect native builds
and doesn't cover the nativesdk case. This converts the recipe to use PN
instead which is more accurate and ensures the correct entries making it
into the correct packages.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gnu-config/gnu-config_20111111.bb
meta/recipes-devtools/gnu-config/gnu-config_git.bb

index 0c652c27b566fa1f218989dde6ef7b36d17e5d61..d4588daa81e6889c5999c3bf7264de39b6cacdd0 100644 (file)
@@ -28,7 +28,7 @@ do_install () {
                sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \
                    -e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize
        # In the native case we want the system perl as perl-native can't have built yet
-       if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then
+       if [ "${PN}" != "gnu-config-native" -a "${PN}" != "gnu-config-nativesdk" ]; then
                sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize
        fi
        chmod 755 ${D}${bindir}/gnu-configize
index 0fdee66ba48d474c27d00d92934ad14f8a977b99..4de479915bcd8b155601139bf15d8c37367fb0e6 100644 (file)
@@ -29,7 +29,7 @@ do_install () {
                sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \
                    -e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize
        # In the native case we want the system perl as perl-native can't have built yet
-       if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then
+       if [ "${PN}" != "gnu-config-native" -a "${PN}" != "gnu-config-nativesdk" ]; then
                sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize
        fi
        chmod 755 ${D}${bindir}/gnu-configize