]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: Small cleanups of metadata
authorScott Garman <scott.a.garman@intel.com>
Wed, 19 Jan 2011 15:03:53 +0000 (15:03 +0000)
committerSaul Wold <sgw@linux.intel.com>
Fri, 21 Jan 2011 09:36:14 +0000 (01:36 -0800)
[based on sections of a patch by Scott Garman extracted by Richard]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/libtool/libtool-native_2.4.bb
meta/recipes-devtools/libtool/libtool.inc
meta/recipes-devtools/libtool/libtool_2.4.bb

index 4ad660b5078943da0c2b3eb1d2be7c2ffbc16960..0c6f54a156937d65c23940854e65726267d7c925 100644 (file)
@@ -21,5 +21,3 @@ do_install () {
        install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
 }
 
-SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
-SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"
index 9690e3b7bfb3d804ca95eaeee4188d2254813631..370d972aca67bfbd58ef68817ec8cb931212beed 100644 (file)
@@ -1,14 +1,22 @@
 SUMMARY = "Generic library support script"
-DESCRIPTION = "This is GNU libtool, a generic library support script.  Libtool hides \
-the complexity of generating special library types (such as shared \
-libraries) behind a consistent interface."
+DESCRIPTION = "This is GNU libtool, a generic library support script. \
+Libtool hides the complexity of generating special library types \
+(such as shared libraries) behind a consistent interface."
 HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
 SECTION = "devel"
 LICENSE = "GPLv2, LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
-    file://libltdl/COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06 "
+    file://libltdl/COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
 
 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
            file://trailingslash.patch \
            file://prefix-manpage-fix.patch "
 
+do_compile_prepend () {
+       # Sometimes this file doesn't get rebuilt, force the issue
+       rm -f ${S}/libltdl/config/ltmain.sh
+       make libltdl/config/ltmain.sh
+}
+
+inherit autotools
+EXTRA_AUTORECONF = "--exclude=libtoolize"
index 0a15fde12656158752ed374b1926656b75c357cb..1e5ce92130dad3a5e80325b5c42f9db5405e1687 100644 (file)
@@ -9,16 +9,6 @@ FILES_libltdl = "${libdir}/libltdl.so.*"
 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h ${includedir}/libltdl/* ${datadir}/aclocal/ltdl.m4 ${datadir}/libtool/libltdl/*"
 FILES_libltdl-dbg = "${libdir}/.debug/"
 
-inherit autotools
-
-EXTRA_AUTORECONF = "--exclude=libtoolize"
-
-do_compile_prepend () {
-       # Sometimes this file doesn't get rebuilt, force the issue
-       rm -f ${S}/libltdl/config/ltmain.sh
-       make libltdl/config/ltmain.sh
-}
-
 #
 # We want the results of libtool-cross preserved - don't stage anything ourselves.
 #