]> code.ossystems Code Review - openembedded-core.git/commitdiff
eee-acpi-scripts: Initial commit
authorSamuel Ortiz <sameo@openedhand.com>
Thu, 25 Sep 2008 14:58:13 +0000 (14:58 +0000)
committerSamuel Ortiz <sameo@openedhand.com>
Thu, 25 Sep 2008 14:58:13 +0000 (14:58 +0000)
eeePC specific ACPI hooks.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5272 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb [new file with mode: 0644]
meta/packages/eee-acpi-scripts/files/policy-funcs [new file with mode: 0644]
meta/packages/eee-acpi-scripts/files/remove-doc-check.patch [new file with mode: 0644]

diff --git a/meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb b/meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb
new file mode 100644 (file)
index 0000000..84cf8a0
--- /dev/null
@@ -0,0 +1,35 @@
+SECTION = "base"
+DESCRIPTION = "eeePC specific ACPI scripts"
+LICENSE="GPL"
+
+SRCREV = "df785afdacedf869b20fb88a793c13b539819270"
+
+PR = "r2"
+
+RDEPENDS = "pm-utils"
+
+SRC_URI = "git://git.debian.org/git/debian-eeepc/eeepc-acpi-scripts.git;protocol=git \
+          file://remove-doc-check.patch;patch=1 \
+          file://policy-funcs "
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${datadir}/acpi-support/ \
+               ${datadir}/eeepc-acpi-scripts \
+               ${sysconfdir}/default/ \
+               ${sysconfdir}/acpi/"
+
+do_install () {
+       install -d ${D}${sysconfdir}/default/
+       install -d ${D}${sysconfdir}/acpi/actions/
+       install -d ${D}${sysconfdir}/acpi/events/
+       install -d ${D}${sysconfdir}/acpi/lib/
+       install -d ${D}${datadir}/eeepc-acpi-scripts/
+       install -d ${D}${datadir}/acpi-support/
+       install -m 644 ${S}/events/* ${D}${sysconfdir}/acpi/events/
+       install -m 644 ${S}/lib/* ${D}${sysconfdir}/acpi/lib/
+       install ${S}/actions/* ${D}${sysconfdir}/acpi/actions/
+       install -m 0644 ${S}/functions.sh ${D}${datadir}/eeepc-acpi-scripts/
+       install -m 0644 ${WORKDIR}/policy-funcs ${D}${datadir}/acpi-support/
+       install -m 0644 ${S}/debian/eeepc-acpi-scripts.default ${D}${sysconfdir}/default/
+}
diff --git a/meta/packages/eee-acpi-scripts/files/policy-funcs b/meta/packages/eee-acpi-scripts/files/policy-funcs
new file mode 100644 (file)
index 0000000..fd099df
--- /dev/null
@@ -0,0 +1,8 @@
+CheckPolicy() {
+       if pidof gnome-power-manager kpowersave > /dev/null ||
+          (pidof dcopserver > /dev/null && test -x /usr/bin/dcop && /usr/bin/dcop kded kded loadedModules | grep -q klaptopdaemon) ; then
+               echo 0;
+       else
+               echo 1;
+       fi
+}
diff --git a/meta/packages/eee-acpi-scripts/files/remove-doc-check.patch b/meta/packages/eee-acpi-scripts/files/remove-doc-check.patch
new file mode 100644 (file)
index 0000000..8f6c4fc
--- /dev/null
@@ -0,0 +1,60 @@
+---
+ actions/hotkey.sh     |    3 ---
+ actions/suspend.sh    |    3 ---
+ actions/vga-toggle.sh |    3 ---
+ actions/volume.sh     |    3 ---
+ 4 files changed, 12 deletions(-)
+
+Index: git/actions/hotkey.sh
+===================================================================
+--- git.orig/actions/hotkey.sh 2008-09-25 11:00:58.000000000 +0200
++++ git/actions/hotkey.sh      2008-09-25 11:01:04.000000000 +0200
+@@ -1,8 +1,5 @@
+ #!/bin/sh
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ . /etc/default/eeepc-acpi-scripts
+ . /usr/share/eeepc-acpi-scripts/functions.sh
+ . /etc/acpi/lib/notify.sh
+Index: git/actions/suspend.sh
+===================================================================
+--- git.orig/actions/suspend.sh        2008-09-25 11:00:32.000000000 +0200
++++ git/actions/suspend.sh     2008-09-25 11:00:37.000000000 +0200
+@@ -1,8 +1,5 @@
+ #!/bin/sh
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ if (runlevel | grep -q [06]) || (pidof '/sbin/shutdown' > /dev/null); then
+     exit 0
+ fi
+Index: git/actions/vga-toggle.sh
+===================================================================
+--- git.orig/actions/vga-toggle.sh     2008-09-25 11:02:00.000000000 +0200
++++ git/actions/vga-toggle.sh  2008-09-25 11:02:06.000000000 +0200
+@@ -1,8 +1,5 @@
+ #!/bin/sh
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ . /etc/default/eeepc-acpi-scripts
+ # return: 0 on disconnect, 1 on connected vga, 2 else
+Index: git/actions/volume.sh
+===================================================================
+--- git.orig/actions/volume.sh 2008-09-25 11:02:13.000000000 +0200
++++ git/actions/volume.sh      2008-09-25 11:02:19.000000000 +0200
+@@ -2,9 +2,6 @@
+ # Volume controls
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ . /etc/default/eeepc-acpi-scripts
+ . /usr/share/eeepc-acpi-scripts/functions.sh
+ . /etc/acpi/lib/notify.sh