]> code.ossystems Code Review - openembedded-core.git/commitdiff
Disable pango support in libmatchbox, add gconf dep and enable gconf in
authorChris Lord <chris@openedhand.com>
Mon, 26 Sep 2005 13:20:40 +0000 (13:20 +0000)
committerChris Lord <chris@openedhand.com>
Mon, 26 Sep 2005 13:20:40 +0000 (13:20 +0000)
matchbox-wm

git-svn-id: https://svn.o-hand.com/repos/poky@35 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/libmatchbox/libmatchbox.inc
openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
openembedded/packages/meta/meta-oh.bb

index 44d2efde71bdb19e7c22f21de2f22a953fc66719..e8700cb7b64842c60f4366ba9a2ae8a618e8f226 100644 (file)
@@ -1,12 +1,12 @@
 SECTION = "x11/libs"
 DESCRIPTION = "Matchbox window manager core library"
 LICENSE = "GPL"
-DEPENDS = "x11 xext expat libxft pango jpeg libpng zlib libxsettings-client"
-PR="r1"
+DEPENDS = "x11 xext expat libxft jpeg libpng zlib libxsettings-client"
+PR="r2"
 
 inherit autotools pkgconfig
 
-EXTRA_OECONF = "--enable-jpeg --enable-expat --enable-pango --enable-xsettings"
+EXTRA_OECONF = "--enable-jpeg --enable-expat --enable-xsettings"
 
 S = "${WORKDIR}/libmatchbox-${PV}"
 
index 5ac11d212dcca6937192016614c02bce6cafed3d..0983c6d6792d2970f7210d31012a586b0ec209f4 100644 (file)
@@ -1,10 +1,10 @@
 SECTION = "x11/wm"
 DESCRIPTION = "Matchbox window manager"
 LICENSE = "GPL"
-DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common gconf"
 RDEPENDS = "matchbox-common"
 PV = "0.9.5cvs${CVSDATE}"
-PR = "r2"
+PR = "r3"
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
@@ -26,7 +26,7 @@ FILES_${PN} = "${bindir} \
                ${datadir}/themes/Default/matchbox \
                ${datadir}/themes/MBOpus/matchbox"
 
-EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm --enable-expat"
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm --enable-expat --enable-gconf"
 
 do_install_prepend() {
        install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
index 5839ae0c616e4442a2eed4d18d183fba39480591..49f8dcf99c9dd7131168b6f9d144fe38e7acdeb5 100644 (file)
@@ -2,7 +2,7 @@ PACKAGES = "oh-base-depends oh-task-base"
 # oh-task-base
 DESCRIPTION = "Meta-package for OpenHand Palmtop Environment"
 MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r2"
+PR = "r3"
 
 ALLOW_EMPTY = "1"
 
@@ -36,7 +36,12 @@ oh-task-base = "\
 #    detect-stylus \
 #    xrdb \
 
-RDEPENDS_oh-task-base := "${oh-task-base}"
+RDEPENDS_oh-task-base := "${oh-task-base} \
+                          gdk-pixbuf-loader-png \
+                         gdk-pixbuf-loader-xpm \
+                         gdk-pixbuf-loader-jpeg \
+                         pango-module-basic-x \
+                         pango-module-basic-fc"
 
 DEPENDS += " ${oh-task-base}"