]> code.ossystems Code Review - openembedded-core.git/commitdiff
bison: Fix gplv2 version to work with recent gettext
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 19 Oct 2012 13:03:32 +0000 (13:03 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 19 Oct 2012 13:06:01 +0000 (14:06 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/bison/bison_2.3.bb

index 388476b4621bf302e594f74fb374e7299c4dc094..86edf3ee1d04649baef54c7eaf74dc51a01d3da0 100644 (file)
@@ -25,6 +25,11 @@ SRC_URI_virtclass-native = "${BASE_SRC_URI}"
 inherit autotools gettext
 acpaths = "-I ${S}/m4"
 
+do_configure_prepend () {
+       rm -f ${S}/m4/*gl.m4
+       cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/runtime-po/
+}
+
 do_install_append_virtclass-native() {
        create_wrapper ${D}/${bindir}/bison \
                M4=${STAGING_BINDIR_NATIVE}/m4 \