]> code.ossystems Code Review - openembedded-core.git/commitdiff
git: use DESTDIR=$D instead prefixing all variables by $D
authorMartin Jansa <martin.jansa@gmail.com>
Fri, 29 Apr 2011 10:13:46 +0000 (12:13 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 May 2011 23:51:54 +0000 (00:51 +0100)
* with git-native and rm_work enabled I've noticed git fetcher errors like:
  warning: templates not found /OE/shr-core/tmp/work/x86_64-linux/git-native-1.7.3.4-r0/image/OE/shr-core/tmp/sysroots/x86_64-linux/usr/share/git-core/templates
  fatal: Unable to find remote helper for 'http'
  for every recipe using http:// for git repo
* after this change template_dir points to
  /OE/shr-core/tmp/sysroots/x86_64-linux/usr/share/git-core/templates
  without that workdir prefix
* haven't tested target recipe, but I guess it needs different fix or
  maybe it worked before and gets broken by this change

[sgw: removed RFC comment, target patch to follow]
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/git/git.inc
meta/recipes-devtools/git/git_1.7.4.3.bb

index e1d1c71c4898a2599c95be0bbd2bc4b78e8c7d49..843a1d3511624b76b265ef387a9a120e06ab268e 100644 (file)
@@ -14,8 +14,8 @@ EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl --without-tcltk"
 inherit autotools
 
 do_install () {
-       oe_runmake install prefix=${D} bindir=${D}${bindir} gitexecdir=${D}${gitexecdir} \
-               template_dir=${D}${datadir}/git-core/templates \
+       oe_runmake install DESTDIR="${D}" bindir=${bindir} gitexecdir=${gitexecdir} \
+               template_dir=${datadir}/git-core/templates \
                GIT_PYTHON_DIR=${D}${datadir}/git-core/python
 }
 
index 603d2fdec0dee3899f6ce110496f8c2d66cce70d..2ff1ed512eafada52374273c3b6f1251567ce6a8 100644 (file)
@@ -1,6 +1,6 @@
 require git.inc
 
-PR = "r0"
+PR = "r1"
 
 EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes \
                  ac_cv_fread_reads_directories=${ac_cv_fread_reads_directories=yes} \