]> code.ossystems Code Review - openembedded-core.git/commitdiff
mdadm: fix usrmerge install path
authorMingli Yu <Mingli.Yu@windriver.com>
Fri, 17 Aug 2018 06:27:09 +0000 (14:27 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 Aug 2018 06:53:09 +0000 (07:53 +0100)
Update /lib to $nonarch_base_libdir to fix
the below error when usrmerge enabled in
DISTRO_FEATURES.

ERROR: mdadm-4.0-r0 do_package_qa: QA Issue: mdadm package is not obeying usrmerge distro feature. /lib should be relocated to /usr. [usrmerge]

Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/mdadm/mdadm_4.0.bb

index 226b974352d0778872ebf3d71fa4eba27c2ab2bd..2c4d88a9e7a5e8b4f082166b5bb159de99d48641 100644 (file)
@@ -42,7 +42,7 @@ CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
 
 do_compile() {
        # Point to right sbindir
-       sed -i -e "s;BINDIR  = /sbin;BINDIR = $base_sbindir;" ${S}/Makefile
+       sed -i -e "s;BINDIR  = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile
        oe_runmake SYSROOT="${STAGING_DIR_TARGET}"
 }