]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-yocto: do_kernel_configme: Fix silent sysroot poisoning error
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>
Tue, 30 Aug 2016 16:49:06 +0000 (12:49 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Sep 2016 10:55:49 +0000 (11:55 +0100)
do_kernel_configme calls merge_config.sh (installed in the sysroot by
the kern-tools-native recipe) which may invoke the compiler to complete
the configuration process.

Depending on the build (and dependencies), this may error due to sysroot poisoning [1].

The errors are similar to:

  make[1]: Entering directory '4.1+gitAUTOINC+a7e53ecc27-r0/linux-x64-standard-build' HOSTCC  scripts/basic/fixdep
  work-shared/x64/kernel-source/scripts/basic/fixdep.c:106:23: fatal error: sys/types.h: No such file or directory
  compilation terminated.
  make[2]: *** [work-shared/x64/kernel-source/scripts/basic/Makefile:22: scripts/basic/x86_64-nilrt-linux-fixdep] Error 1

Adding $TOOLCHAIN_OPTIONS to $CFLAGS before calling merge_configs.sh
fixes the error because $TOOLCHAIN_OPTIONS defines the sysroot and make
uses it to correctly compile & fill all missing kernel config options.

[1] http://lists.openembedded.org/pipermail/openembedded-core/2014-October/098253.html

Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel-yocto.bbclass

index 9b8bab63ca0909e47ea820dbaac7606e6607d0c3..068378f06796ca83464f384790b0ef14ab45d08b 100644 (file)
@@ -255,7 +255,7 @@ do_kernel_configme() {
                bbfatal_log "Could not find configuration queue (${meta_dir}/config.queue)"
        fi
 
-       ARCH=${ARCH} merge_config.sh -O ${B} ${config_flags} ${configs} > ${meta_dir}/cfg/merge_config_build.log 2>&1
+       CFLAGS="${CFLAGS} ${TOOLCHAIN_OPTIONS}" ARCH=${ARCH} merge_config.sh -O ${B} ${config_flags} ${configs} > ${meta_dir}/cfg/merge_config_build.log 2>&1
        if [ $? -ne 0 ]; then
                bbfatal_log "Could not configure ${KMACHINE}-${LINUX_KERNEL_TYPE}"
        fi