]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: create staging directories before installing into them (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 12:53:16 +0000 (12:53 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 12:53:16 +0000 (12:53 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3006 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/libxml/libxml2_2.6.29.bb

index 6904031670bb4f7b35dbbe642ae454327c8b38ed..521ba16d9bf378a84fe19302e4353ee11b487924 100644 (file)
@@ -14,9 +14,12 @@ export LDFLAGS += "-ldl"
 
 do_stage() {
        autotools_stage_all
-       install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
-        #this is need it by php during its install
-        install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
+       install -d ${STAGING_DATADIR}/aclocal/
+       install -d ${STAGING_BINDIR_CROSS}
+
+       install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+       #this is need it by php during its install
+       install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
 }
 
 python populate_packages_prepend () {