]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: fix wrongfully used qemuarma15 in place of qemuarmv5
authorDenys Dmytriyenko <denys@ti.com>
Thu, 21 Mar 2019 04:50:52 +0000 (00:50 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 24 Mar 2019 17:00:42 +0000 (17:00 +0000)
Commit 6fc70eb4f3494bee2be10ee24fe3ea1c8b5ff988 changes "qemuarm" machine from
old ARMv5 to a newer Cortex-A15, moving the old platform under "qemuarmv5" name.
When adding this new "old" platform name to COMPATIBLE_MACHINE in linux-yocto
recipes, mistakes were made referring it by "qemuarma15", as discussed in [1].
This change fixes those mistakes.

[1]http://lists.openembedded.org/pipermail/openembedded-core/2019-March/280292.html

Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
meta/recipes-kernel/linux/linux-yocto_4.19.bb

index 36761b99437fa6a68b101e0ec8f056d0de0475a8..c3f9d5facdd0077d97a158b78e1bb6ca30d641ad 100644 (file)
@@ -31,7 +31,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 
 LINUX_KERNEL_TYPE = "preempt-rt"
 
-COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuarma15|qemuarm64|qemuppc|qemumips)"
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuarmv5|qemuarm64|qemuppc|qemumips)"
 
 KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
 
index 52dbabd7a47d488a72a30d2ffa21c3e5856a7866..2d85817bdd873158c81cb17334a270ee928e0522 100644 (file)
@@ -24,7 +24,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"
 
-COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarma15"
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
 
 # Functionality flags
 KERNEL_FEATURES = ""
index aca9f15404ea9ed465223865afbbebf24ad18e68..340e950f630b7583c32ab0e25eecdcfe98e7d846 100644 (file)
@@ -38,7 +38,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 
 KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
 
-COMPATIBLE_MACHINE = "qemuarm|qemuarma15|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
+COMPATIBLE_MACHINE = "qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
 
 # Functionality flags
 KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"