]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: disable harfbuzz
authorRoss Burton <ross.burton@intel.com>
Wed, 14 May 2014 10:13:19 +0000 (11:13 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 May 2014 12:42:09 +0000 (13:42 +0100)
Freetype has an automatically detected dependency on Harfbuzz, which has a
dependency on Freetype.

To produce deterministic builds and avoid link failures when rebuilding freetype
with harfbuzz present add a PACKAGECONFIG for Harfbuzz and disable it by
default.

(From OE-Core rev: 17131d42c02b591e1b6d547852cb09b004b8d609)

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/freetype/freetype_2.5.2.bb

index 0c62a678cd968e8c39d6b082414a5ce74dbd0701..fd8a9e184e361814b8269af02a4d75d3d36fbced 100644 (file)
@@ -30,6 +30,8 @@ EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
+# This results in a circular dependency so enabling is non-trivial
+PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
 
 do_configure() {
        cd builds/unix