]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot: Use fw_env.config if avaliable
authorFranklin S. Cooper Jr <fcooperjr27@gmail.com>
Mon, 17 Sep 2012 18:12:55 +0000 (13:12 -0500)
committerScott Garman <scott.a.garman@intel.com>
Mon, 24 Sep 2012 16:51:14 +0000 (09:51 -0700)
* Add support for board specific fw_env.config file if avaliable

Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
meta/recipes-bsp/u-boot/u-boot.inc
meta/recipes-bsp/u-boot/u-boot_2011.03.bb
meta/recipes-bsp/u-boot/u-boot_2011.06.bb

index e627e978c857b1ec08486a3f9ccbde74ed766512..3086814ea38bab6fa1db3f0ab11c0b19e3112fb6 100644 (file)
@@ -48,6 +48,11 @@ do_install () {
     install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
     ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
 
+    if [ -e ${WORKDIR}/fw_env.config ] ; then
+        install -d ${D}${sysconfdir}
+        install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+    fi
+
     if [ "x${SPL_BINARY}" != "x" ]
     then
         install ${S}/${SPL_BINARY} ${D}/boot/${SPL_IMAGE}
@@ -55,15 +60,16 @@ do_install () {
     fi
 }
 
-FILES_${PN} = "/boot"
+FILES_${PN} = "/boot ${sysconfdir}"
 
 do_deploy () {
     install -d ${DEPLOYDIR}
-       install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
+    install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
 
-       cd ${DEPLOYDIR}
-       rm -f ${UBOOT_SYMLINK}
-       ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+    cd ${DEPLOYDIR}
+    rm -f ${UBOOT_BINARY} ${UBOOT_SYMLINK}
+    ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+    ln -sf ${UBOOT_IMAGE} ${UBOOT_BINARY}
 
     if [ "x${SPL_BINARY}" != "x" ]
     then
index 5d79e1a0ab78497f05d2e68ce17dd65aaa0023f8..fa328d1a43ff6d196c887cc55393fb1162adcfad 100644 (file)
@@ -17,7 +17,7 @@ FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/u-boot-git/${MACHINE}"
 SRCREV = "19b54a701811220221fc4d5089a2bb18892018ca"
 
 PV = "v2011.03+git${SRCPV}"
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
 
index 43f2c0661b593761eb90b43be435c2075d9b055c..93b79238b095ecc2dad8f300b04269542aa8c63e 100644 (file)
@@ -17,7 +17,7 @@ FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/u-boot-git/${MACHINE}"
 SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a"
 
 PV = "v2011.06+git${SRCPV}"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"