]> code.ossystems Code Review - openembedded-core.git/commitdiff
remake: fix insufficient gettext dependency
authorPetter Mabäcker <petter@technux.se>
Mon, 15 Jul 2013 16:53:25 +0000 (18:53 +0200)
committerSaul Wold <sgw@linux.intel.com>
Tue, 23 Jul 2013 14:22:37 +0000 (07:22 -0700)
By default when inheriting gettext, "gettext-minimal-native" is added as
a dependency for native. The bb-file for remake use 'autopoint' (not
included in gettext-minimal-native). When building remake-native it
will result in a failure in do_configure for all cases when gettext (or
gettext-native) is not build from some other recipes, before building
'remake-native'.

This is solved by adding a build-dependency to gettext-native in
remake-native.

Fixes [YOCTO #4385]

Signed-off-by: Petter Mabäcker <petter@technux.se>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/remake/remake_git.bb

index 13d8ce92a3525883ac1913f6cc35617e8fc76f42..405c69f6a6e739679ad904b21423bbe5ccd2564c 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                     file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
@@ -12,6 +12,10 @@ S = "${WORKDIR}/git"
 PV = "3.82+dbg-0.9+git${SRCPV}"
 
 DEPENDS += "readline"
+# Need to add "gettext-native" dependency to remake-native.
+# By default only "gettext-minimal-native" is added
+# when inherit gettext.
+DEPENDS_class-native += "gettext-native"
 PROVIDES += "make"
 
 do_configure_prepend() {