]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer1.0-python: Set internal python library path correcty
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Feb 2021 12:05:14 +0000 (12:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Mar 2021 00:17:41 +0000 (00:17 +0000)
The library hardcodes paths to the python library internally and currently
these are build paths. Fix this to use the correct target path and
fix reproducibility in the process.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/selftest/cases/reproducible.py
meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.3.bb

index bf7064d18bae8589b3d059c42db152eb1774f428..fcd9d83ab8650d80d797b407c6bfb0452c102599 100644 (file)
@@ -35,7 +35,6 @@ exclude_packages = [
        'go-runtime',
        'go_',
        'go-',
-       'gstreamer1.0-python',
        'lttng-tools-dbg',
        'lttng-tools-ptest',
        'ltp',
index 897d24679378f06620406ff5be99c04b4fdc8279..de78fe8445245d2504c6ce0703f3e1bc5ce88954 100644 (file)
@@ -15,6 +15,8 @@ PNREAL = "gst-python"
 
 S = "${WORKDIR}/${PNREAL}-${PV}"
 
+EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
+
 # gobject-introspection is mandatory and cannot be configured
 REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
 UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"