]> code.ossystems Code Review - openembedded-core.git/commitdiff
xf86-video-omap: skip package if opengl isn't in DISTRO_FEATURES
authorMartin Jansa <martin.jansa@gmail.com>
Tue, 25 Dec 2012 18:43:59 +0000 (19:43 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Dec 2012 09:42:49 +0000 (09:42 +0000)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb

index dea8ca28a0bc376883a75a1a72b068f031a105f6..f74419f94f35065426d410891aa84c51eb0247d7 100644 (file)
@@ -40,3 +40,9 @@ CFLAGS += " -I${STAGING_INCDIR}/xorg "
 do_compile_prepend_armv7a () {
         sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c
 }
+
+python () {
+    if not oe.utils.contains ('DISTRO_FEATURES', 'opengl', True, False, d):
+        raise bb.parse.SkipPackage("'opengl' not in DISTRO_FEATURES")
+}
+