]> code.ossystems Code Review - openembedded-core.git/commitdiff
libc-headers: update to v5.8
authorBruce Ashfield <bruce.ashfield@gmail.com>
Wed, 19 Aug 2020 13:24:39 +0000 (09:24 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Aug 2020 14:28:57 +0000 (15:28 +0100)
Updating the libc-headers to v5.8. Adjustments to the recipe
include:

The license checksum. Needs to be updated to account for kernel
commit 74835c7db0322b [COPYING: state that all contributions really are
covered by this file].

And the ARM multilib headers need to check the version to adjust for
kernel commit: 541ad0150ca4 [arm: Remove 32bit KVM host support]. We
don't want to break potential other libc-header users, so we check
the version and continue to install the file if the version is less
than v5.8

One patch is refreshed to remove fuzz when building musl.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/tcmode-default.inc
meta/recipes-kernel/linux-libc-headers/linux-libc-headers.inc
meta/recipes-kernel/linux-libc-headers/linux-libc-headers/0001-include-linux-stddef.h-in-swab.h-uapi-header.patch
meta/recipes-kernel/linux-libc-headers/linux-libc-headers_5.8.bb [moved from meta/recipes-kernel/linux-libc-headers/linux-libc-headers_5.4.bb with 71% similarity]

index d5e0e9ebbb21826c0dacc614f3e21bfd0d670198..4f29d00e996cf601a97bd901803e275efb6a514d 100644 (file)
@@ -21,7 +21,7 @@ SDKGCCVERSION ?= "${GCCVERSION}"
 BINUVERSION ?= "2.35%"
 GDBVERSION ?= "9.%"
 GLIBCVERSION ?= "2.32"
-LINUXLIBCVERSION ?= "5.4%"
+LINUXLIBCVERSION ?= "5.8%"
 QEMUVERSION ?= "5.1%"
 GOVERSION ?= "1.14%"
 # This can not use wildcards like 8.0.% since it is also used in mesa to denote
index 20139a84972d73c8c312317943c4af7d966974ce..b1cb553c7525e6731e318ef3196e78d3134492bc 100644 (file)
@@ -30,7 +30,7 @@ LICENSE = "GPLv2"
 #
 # -- RP
 
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+LIC_FILES_CHKSUM ?= "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
 
 RECIPE_NO_UPDATE_REASON = "Recipe is updated through a separate process"
 
@@ -46,6 +46,9 @@ python __anonymous () {
         d.setVar("HEADER_FETCH_VER", "2.6")
 }
 
+MAJ_VER = "${@oe.utils.trim_version("${PV}", 2).split('.')[0]}"
+MIN_VER = "${@oe.utils.trim_version("${PV}", 2).split('.')[1]}"
+
 inherit kernel-arch pkgconfig multilib_header
 
 KORG_ARCHIVE_COMPRESSION ?= "xz"
@@ -83,7 +86,16 @@ do_install_append_armeb () {
 }
 
 do_install_armmultilib () {
-       oe_multilib_header asm/auxvec.h asm/bitsperlong.h asm/byteorder.h asm/fcntl.h asm/hwcap.h asm/ioctls.h asm/kvm.h asm/kvm_para.h asm/mman.h asm/param.h asm/perf_regs.h asm/bpf_perf_event.h
+       if [ ${MAJ_VER} -gt 5 ]; then
+               ARM_KVM_HEADER=""
+       else
+               if [ ${MAJ_VER} -eq 5 ] && [ ${MIN_VER} -ge 8 ]; then
+                       ARM_KVM_HEADER=""
+               else
+                       ARM_KVM_HEADER="asm/kvm.h"
+               fi
+       fi
+       oe_multilib_header asm/auxvec.h asm/bitsperlong.h asm/byteorder.h asm/fcntl.h asm/hwcap.h asm/ioctls.h $ARM_KVM_HEADER asm/kvm_para.h asm/mman.h asm/param.h asm/perf_regs.h asm/bpf_perf_event.h
        oe_multilib_header asm/posix_types.h asm/ptrace.h  asm/setup.h  asm/sigcontext.h asm/siginfo.h asm/signal.h asm/stat.h  asm/statfs.h asm/swab.h  asm/types.h asm/unistd.h
 }
 
index 9d17daa70f08312aa016fae17a8be48c05b4bc2d..5b7c1b6e21e6919650d7b77e5e3f00d4a634a817 100644 (file)
@@ -1,4 +1,4 @@
-From 9708dc74d9f49488d669e070982f6224a888d61a Mon Sep 17 00:00:00 2001
+From dc221138c809125dc1bbff8506c70cb7bd846368 Mon Sep 17 00:00:00 2001
 From: Khem Raj <raj.khem@gmail.com>
 Date: Wed, 12 Sep 2018 17:08:58 -0700
 Subject: [PATCH] include linux/stddef.h in swab.h uapi header
@@ -23,12 +23,13 @@ Cc: Philippe Ombredanne <pombredanne@nexb.com>
 Cc: Kate Stewart <kstewart@linuxfoundation.org>
 Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 Cc: Thomas Gleixner <tglx@linutronix.de>
+
 ---
  include/uapi/linux/swab.h | 1 +
  1 file changed, 1 insertion(+)
 
 diff --git a/include/uapi/linux/swab.h b/include/uapi/linux/swab.h
-index 23cd84868cc3..acddbe50a20d 100644
+index 7272f85d6..2912fe463 100644
 --- a/include/uapi/linux/swab.h
 +++ b/include/uapi/linux/swab.h
 @@ -3,6 +3,7 @@
@@ -37,8 +38,5 @@ index 23cd84868cc3..acddbe50a20d 100644
  #include <linux/types.h>
 +#include <linux/stddef.h>
  #include <linux/compiler.h>
+ #include <asm/bitsperlong.h>
  #include <asm/swab.h>
--- 
-2.19.0
-
similarity index 71%
rename from meta/recipes-kernel/linux-libc-headers/linux-libc-headers_5.4.bb
rename to meta/recipes-kernel/linux-libc-headers/linux-libc-headers_5.8.bb
index 8a12103ee5d70783b32f5644f7d7ee495a3ce8df..d76a8a36f81cfe1090df4d4614d0469b5ca66ba9 100644 (file)
@@ -12,5 +12,7 @@ SRC_URI_append = "\
     file://0001-kbuild-install_headers.sh-Strip-_UAPI-from-if-define.patch \
 "
 
-SRC_URI[md5sum] = "ce9b2d974d27408a61c53a30d3f98fb9"
-SRC_URI[sha256sum] = "bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+SRC_URI[md5sum] = "0e5c4c15266218ef26c50fac0016095b"
+SRC_URI[sha256sum] = "e7f75186aa0642114af8f19d99559937300ca27acaf7451b36d4f9b0f85cf1f5"