]> code.ossystems Code Review - openembedded-core.git/commitdiff
dtc: Add patch to correctly install shared libraries and links
authorSaul Wold <sgw@linux.intel.com>
Thu, 3 Nov 2011 15:35:47 +0000 (08:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Nov 2011 14:03:25 +0000 (14:03 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/dtc/dtc.inc
meta/recipes-kernel/dtc/dtc/make_install.patch [new file with mode: 0644]

index 0f45d5f08eddde7c92e051b55611b1a97b6959ca..9b4b7682b8653b21bb1d6f4e18aca0b4576e8696 100644 (file)
@@ -7,10 +7,11 @@ DEPENDS = "flex-native bison-native"
 inherit autotools
 
 SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
+           file://make_install.patch \
          "
 
 EXTRA_OEMAKE='PREFIX="${prefix}"'
-INC_PR = "r1"
+INC_PR = "r2"
 
 S = "${WORKDIR}/git"
 
diff --git a/meta/recipes-kernel/dtc/dtc/make_install.patch b/meta/recipes-kernel/dtc/dtc/make_install.patch
new file mode 100644 (file)
index 0000000..2f7d809
--- /dev/null
@@ -0,0 +1,15 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile  2011-11-02 14:52:17.243104779 -0700
++++ git/Makefile       2011-11-02 15:06:01.555104982 -0700
+@@ -161,8 +161,8 @@
+       $(INSTALL) -d $(DESTDIR)$(BINDIR)
+       $(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
+       $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+-      $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
+-      ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
++      $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
++      ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
+       ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
+       $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
+       $(INSTALL) -d $(DESTDIR)$(INCLUDEDIR)