]> code.ossystems Code Review - openembedded-core.git/commitdiff
RPM: multilib file class/color
authorMark Hatle <mark.hatle@windriver.com>
Wed, 29 Jun 2011 20:41:59 +0000 (15:41 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 14:44:31 +0000 (15:44 +0100)
We need to include file class and file color in order to do the conflict
resolution required with a multilib design.  This is normally disabled when
we don't use the internal dependency generator, patch enables it in
all cases.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch [new file with mode: 0644]
meta/recipes-devtools/rpm/rpm_5.4.0.bb

diff --git a/meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch b/meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch
new file mode 100644 (file)
index 0000000..d1e4bf6
--- /dev/null
@@ -0,0 +1,34 @@
+rpmfc.c:  Always generate per-file information
+
+Even when the per-file dependency generate is disabled, we want to generate
+per file classification and other associated data.
+
+Note: this is a temporary workaround.  Eventually we will want to have a way
+to seed per-file dependency and other information in order to generate a
+package from previously determined information.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff --git a/lib/rpmfc.c b/lib/rpmfc.c
+index 0c3befd..9306999 100644
+--- a/lib/rpmfc.c
++++ b/lib/rpmfc.c
+@@ -1692,7 +1692,6 @@ rpmRC rpmfcGenerateDepends(void * specp, void * pkgp)
+       /* ... then generate dependencies using %{__find_requires} et al. */
+       rc = rpmfcGenerateDependsHelper(spec, pkg, fi);
+       printDeps(pkg->header);
+-      return rc;
+     }
+     /* Generate scriptlet Dependencies. */
+@@ -1720,8 +1719,8 @@ rpmRC rpmfcGenerateDepends(void * specp, void * pkgp)
+     av[ac] = NULL;
+     fc = rpmfcNew();
+-    fc->skipProv = !pkg->autoProv;
+-    fc->skipReq = !pkg->autoReq;
++    fc->skipProv = !pkg->autoProv || !internaldeps;
++    fc->skipReq = !pkg->autoReq || !internaldeps;
+     fc->tracked = 0;
+     { const char * buildRootURL;
index 9cfb3ab03b9e16ed5067c5960e28a2a4f9865c80..c0e320838333e78d3bc85e12357619e59d9a0535 100644 (file)
@@ -60,6 +60,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.0-0.20101229.src.rpm;ex
           file://rpm-solvedb.patch \
           file://rpm-tools-mtree-LDFLAGS.patch \
           file://fprint-pointer-fix.patch \
+          file://rpm-fileclass.patch \
          "
 
 #           file://hdraddorappend.patch \