]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Security fix for CVE-2016-4002
authorArmin Kuster <akuster@mvista.com>
Tue, 20 Sep 2016 02:56:19 +0000 (19:56 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Sep 2016 14:26:35 +0000 (15:26 +0100)
affects qemu < 2.6.0

Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-devtools/qemu/qemu/CVE-2016-4002.patch [new file with mode: 0644]
meta/recipes-devtools/qemu/qemu_2.5.0.bb

diff --git a/meta/recipes-devtools/qemu/qemu/CVE-2016-4002.patch b/meta/recipes-devtools/qemu/qemu/CVE-2016-4002.patch
new file mode 100644 (file)
index 0000000..69c11e2
--- /dev/null
@@ -0,0 +1,39 @@
+From 7a2c32ec06533c54ddaf70136bfbd89eeaf6db16 Mon Sep 17 00:00:00 2001
+From: Prasad J Pandit <pjp@fedoraproject.org>
+Date: Thu, 7 Apr 2016 15:56:02 +0530
+Subject: [PATCH] net: mipsnet: check packet length against buffer
+
+When receiving packets over MIPSnet network device, it uses
+receive buffer of size 1514 bytes. In case the controller
+accepts large(MTU) packets, it could lead to memory corruption.
+Add check to avoid it.
+
+Reported by: Oleksandr Bazhaniuk <oleksandr.bazhaniuk@intel.com>
+Signed-off-by: Prasad J Pandit <pjp@fedoraproject.org>
+Signed-off-by: Jason Wang <jasowang@redhat.com>
+
+(cherry picked from commit 3af9187fc6caaf415ab9c0c6d92c9678f65cb17f)
+Signed-off-by: Michael Roth <mdroth@linux.vnet.ibm.com>
+
+Upstream-Status: Backport
+CVE: CVE-2016-4002
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ hw/net/mipsnet.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+Index: qemu-2.4.0/hw/net/mipsnet.c
+===================================================================
+--- qemu-2.4.0.orig/hw/net/mipsnet.c
++++ qemu-2.4.0/hw/net/mipsnet.c
+@@ -82,6 +82,9 @@ static ssize_t mipsnet_receive(NetClient
+     if (!mipsnet_can_receive(nc))
+         return 0;
++    if (size >= sizeof(s->rx_buffer)) {
++        return 0;
++    }
+     s->busy = 1;
+     /* Just accept everything. */
index feb63525317945342a20e646f136769e5564fe58..0ffec9889c59c0451e65b90e2dd24d6be312a707 100644 (file)
@@ -24,6 +24,7 @@ SRC_URI += "file://configure-fix-Darwin-target-detection.patch \
             file://CVE-2016-4439.patch \
             file://CVE-2016-6351_p1.patch \
             file://CVE-2016-6351_p2.patch \
+            file://CVE-2016-4002.patch \
            "
 SRC_URI_prepend = "http://wiki.qemu-project.org/download/${BP}.tar.bz2"
 SRC_URI[md5sum] = "f469f2330bbe76e3e39db10e9ac4f8db"