]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Undefine finitel for uclibc
authorYen-Chin Lee <coldnew.tw@gmail.com>
Wed, 19 Aug 2015 05:54:03 +0000 (05:54 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 24 Aug 2015 22:43:27 +0000 (23:43 +0100)
finitel is not implemented in uclibc and since its not posix, it wont be
implemented in future too.

Fixes perl 5.22 build error

perl/5.22.0-r0/perl-5.22.0/sv.c:12135: undefined reference to `finitel'
 | collect2: error: ld returned 1 exit status

Signed-off-by: Yen-Chin Lee <coldnew.tw@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/perl/perl_5.22.0.bb

index e3a7f418865d240138bd19bef5d0350484e09308..3ce7849f9e57c9173a07bf044e2161027df14fef 100644 (file)
@@ -134,6 +134,7 @@ do_configure() {
         if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
                 sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
                        -e "s,\(d_futimes=\)'define',\1'undef',g" \
+                       -e "s,\(d_finitel=\)'define',\1'undef',g" \
                        -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
                        -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
                        -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \