]> code.ossystems Code Review - openembedded-core.git/commitdiff
grep: Always use locale.h
authorAlexandru DAMIAN <alexandru.damian@intel.com>
Tue, 12 Mar 2013 09:56:02 +0000 (09:56 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Mar 2013 17:25:36 +0000 (17:25 +0000)
The changes in the grep 2.5 configuration always leave out
HAVE_LOCALE_H - it has been removed from other files, but
not from everywhere.

This leads to a crash in certain configurations where the
size of int is not the size of pointer; this happens because
setlocale() is used while being undeclared.

[YOCTO #3959]

Signed-off-by: Alexandru DAMIAN <alexandru.damian@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/grep/grep-2.5.1a/fix64-int-to-pointer.patch [new file with mode: 0644]
meta/recipes-extended/grep/grep_2.5.1a.bb

diff --git a/meta/recipes-extended/grep/grep-2.5.1a/fix64-int-to-pointer.patch b/meta/recipes-extended/grep/grep-2.5.1a/fix64-int-to-pointer.patch
new file mode 100644 (file)
index 0000000..3b91520
--- /dev/null
@@ -0,0 +1,17 @@
+Always use locale.h as HAVE_LOCALE_H is no longer handled by ./configure
+Upstream-Status: Inappropriate [ old version that will not be maintained ]
+Signed-off-by: Alex DAMIAN <alexandru.damian@intel.com>
+
+diff --recursive --unified grep-2.5.1a-orig/lib/hard-locale.c grep-2.5.1a/lib/hard-locale.c
+--- grep-2.5.1a-orig/lib/hard-locale.c 2001-03-04 07:33:12.000000000 +0200
++++ grep-2.5.1a/lib/hard-locale.c      2013-03-11 17:05:52.086444891 +0200
+@@ -38,9 +38,7 @@
+ # endif
+ #endif
+-#if HAVE_LOCALE_H
+ # include <locale.h>
+-#endif
+ #if HAVE_STRING_H
+ # include <string.h>
index ebcbe23ca0a487859714cbf744c0988790a785c1..d6386edb3f6828da1c258f874bb00f79bdb2eed7 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
            file://uclibc-fix.patch \
            file://grep_fix_for_automake-1.12.patch \
            file://gettext.patch \
+           file://fix64-int-to-pointer.patch \
            file://Makevars \
            "