]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-pbr: add it for python3-testtools
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 27 Jul 2018 06:59:25 +0000 (14:59 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Jul 2018 11:44:28 +0000 (12:44 +0100)
- The python3-testtools RDEPENDS on it.
- It is from meta-python, I extended it to nativesdk.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-pbr.inc [new file with mode: 0644]
meta/recipes-devtools/python/python3-pbr_3.1.1.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python-pbr.inc b/meta/recipes-devtools/python/python-pbr.inc
new file mode 100644 (file)
index 0000000..0b70883
--- /dev/null
@@ -0,0 +1,15 @@
+SUMMARY = "Python Build Reasonableness"
+DESCRIPTION = "PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "4e82c2e07af544c56a5b71c801525b00"
+SRC_URI[sha256sum] = "05f61c71aaefc02d8e37c0a3eeb9815ff526ea28b3b76324769e6158d7f95be1"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pip"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pbr_3.1.1.bb b/meta/recipes-devtools/python/python3-pbr_3.1.1.bb
new file mode 100644 (file)
index 0000000..97e7361
--- /dev/null
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pbr.inc