]> code.ossystems Code Review - openembedded-core.git/commitdiff
musl: Update to tip of master
authorKhem Raj <raj.khem@gmail.com>
Fri, 26 Jun 2020 03:45:24 +0000 (20:45 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Jun 2020 07:23:12 +0000 (08:23 +0100)
Detailed changelog [1]
Refresh patches

[1] https://git.musl-libc.org/cgit/musl/log/?qt=range&q=1b4e84c56df0f8ca30f6bc05962a860f869e71df..fca7428c096066482d8c3f52450810288e27515c

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/musl/musl/0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch
meta/recipes-core/musl/musl/0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch
meta/recipes-core/musl/musl_git.bb

index 462d338b960892a1c3c5589c4f714df6d15bcde7..ba00efe7b375adf7f6e7a693bf6e04c74dcfae02 100644 (file)
@@ -22,11 +22,9 @@ Upstream-Status: Pending
  tools/install.sh | 8 +++++---
  2 files changed, 6 insertions(+), 4 deletions(-)
 
-diff --git a/Makefile b/Makefile
-index 8246b78..d1dbe39 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -215,7 +215,7 @@ $(DESTDIR)$(includedir)/%: $(srcdir)/include/%
+@@ -210,7 +210,7 @@ $(DESTDIR)$(includedir)/%: $(srcdir)/inc
        $(INSTALL) -D -m 644 $< $@
  
  $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so
@@ -35,8 +33,6 @@ index 8246b78..d1dbe39 100644
  
  install-libs: $(ALL_LIBS:lib/%=$(DESTDIR)$(libdir)/%) $(if $(SHARED_LIBS),$(DESTDIR)$(LDSO_PATHNAME),)
  
-diff --git a/tools/install.sh b/tools/install.sh
-index d913b60..b6a7f79 100755
 --- a/tools/install.sh
 +++ b/tools/install.sh
 @@ -6,18 +6,20 @@
@@ -62,7 +58,7 @@ index d913b60..b6a7f79 100755
  m) mode=$OPTARG ;;
  ?) usage ;;
  esac
-@@ -48,7 +50,7 @@ trap 'rm -f "$tmp"' EXIT INT QUIT TERM HUP
+@@ -48,7 +50,7 @@ trap 'rm -f "$tmp"' EXIT INT QUIT TERM H
  umask 077
  
  if test "$symlink" ; then
@@ -71,6 +67,3 @@ index d913b60..b6a7f79 100755
  else
  cat < "$1" > "$tmp"
  chmod "$mode" "$tmp"
--- 
-2.7.4
-
index 6a875a717e70c966308cec40ac909f05a36271b8..f57aae5f3ca136996ab8317fac0624058743d27e 100644 (file)
@@ -20,11 +20,9 @@ Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
  ldso/dynlink.c | 4 +++-
  2 files changed, 5 insertions(+), 2 deletions(-)
 
-diff --git a/Makefile b/Makefile
-index b46f8ca4..c07e4ae8 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -46,7 +46,8 @@ CFLAGS_AUTO = -Os -pipe
+@@ -47,7 +47,8 @@ CFLAGS_AUTO = -Os -pipe
  CFLAGS_C99FSE = -std=c99 -ffreestanding -nostdinc 
  
  CFLAGS_ALL = $(CFLAGS_C99FSE)
@@ -34,20 +32,18 @@ index b46f8ca4..c07e4ae8 100644
  CFLAGS_ALL += $(CPPFLAGS) $(CFLAGS_AUTO) $(CFLAGS)
  
  LDFLAGS_ALL = $(LDFLAGS_AUTO) $(LDFLAGS)
-diff --git a/ldso/dynlink.c b/ldso/dynlink.c
-index ec921dfd..7c119c55 100644
 --- a/ldso/dynlink.c
 +++ b/ldso/dynlink.c
-@@ -22,6 +22,8 @@
+@@ -24,6 +24,8 @@
+ #include "libc.h"
  #include "dynlink.h"
- #include "malloc_impl.h"
  
 +#define SYS_PATH_DFLT SYSLIBDIR ":" LIBDIR
 +
  static void error(const char *, ...);
  
  #define MAXP2(a,b) (-(-(a)&-(b)))
-@@ -1038,7 +1040,7 @@ static struct dso *load_library(const char *name, struct dso *needed_by)
+@@ -1071,7 +1073,7 @@ static struct dso *load_library(const ch
                                        sys_path = "";
                                }
                        }
@@ -56,6 +52,3 @@ index ec921dfd..7c119c55 100644
                        fd = path_open(name, sys_path, buf, sizeof buf);
                }
                pathname = buf;
--- 
-2.7.4
-
index 6aa69985d731d7b3eeaf40d29cfc3ce9078ee264..0913b09aaf6c5680a5db13ef8af26e5f084994e4 100644 (file)
@@ -4,7 +4,7 @@
 require musl.inc
 inherit linuxloader
 
-SRCREV = "1b4e84c56df0f8ca30f6bc05962a860f869e71df"
+SRCREV = "fca7428c096066482d8c3f52450810288e27515c"
 
 BASEVER = "1.2.0"