]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-imaging: added from OE (required for flumotion update)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Apr 2008 05:18:13 +0000 (05:18 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Apr 2008 05:18:13 +0000 (05:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4162 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-extras/packages/python/python-imaging/path.patch [new file with mode: 0644]
meta-extras/packages/python/python-imaging_1.1.6.bb [new file with mode: 0644]

diff --git a/meta-extras/packages/python/python-imaging/path.patch b/meta-extras/packages/python/python-imaging/path.patch
new file mode 100644 (file)
index 0000000..1dc467a
--- /dev/null
@@ -0,0 +1,37 @@
+Index: Imaging-1.1.5/setup.py
+===================================================================
+--- Imaging-1.1.5.orig/setup.py        2005-03-23 19:16:40.000000000 +0100
++++ Imaging-1.1.5/setup.py     2006-05-31 14:36:07.000000000 +0200
+@@ -28,12 +28,13 @@
+ #
+ # TIFF_ROOT = libinclude("/opt/tiff")
+-FREETYPE_ROOT = None
+-JPEG_ROOT = None
++FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
++JPEG_ROOT = os.environ['STAGING_LIBDIR']
+ TIFF_ROOT = None
+-ZLIB_ROOT = None
++ZLIB_ROOT = os.environ['STAGING_LIBDIR']
+ TCL_ROOT = None
++
+ # FIXME: add mechanism to explicitly *disable* the use of a library
+ # --------------------------------------------------------------------
+@@ -175,15 +176,6 @@
+             add_directory(include_dirs, include_root)
+         #
+-        # add standard directories
+-
+-        add_directory(library_dirs, "/usr/local/lib")
+-        add_directory(include_dirs, "/usr/local/include")
+-
+-        add_directory(library_dirs, "/usr/lib")
+-        add_directory(include_dirs, "/usr/include")
+-
+-        #
+         # insert new dirs *before* default libs, to avoid conflicts
+         # between Python PYD stub libs and real libraries
diff --git a/meta-extras/packages/python/python-imaging_1.1.6.bb b/meta-extras/packages/python/python-imaging_1.1.6.bb
new file mode 100644 (file)
index 0000000..9f3b632
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "Python Imaging Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "freetype jpeg tiff"
+RDEPENDS = "python-lang python-stringold"
+SRCNAME = "Imaging"
+PR = "ml0"
+
+SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
+           file://path.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_compile() {
+    export STAGING_LIBDIR=${STAGING_LIBDIR}
+    export STAGING_INCDIR=${STAGING_INCDIR}
+    distutils_do_compile
+}
+
+do_install() {
+    export STAGING_LIBDIR=${STAGING_LIBDIR}
+    export STAGING_INCDIR=${STAGING_INCDIR}
+    distutils_do_install
+    install -d ${D}${datadir}/doc/${PN}/html/
+    install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
+    install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+
+}