]> code.ossystems Code Review - openembedded-core.git/commitdiff
file: fix metadata
authorQing He <qing.he@intel.com>
Thu, 1 Jul 2010 08:50:09 +0000 (16:50 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Fri, 2 Jul 2010 22:32:44 +0000 (15:32 -0700)
add homepage, slight re-order

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/file/file_4.18.bb

index 1ff842544750eec9b7e8dc95af3bbd63e478f095..4c8e64c308f0d79859ec587b950f04f5cf70d536 100644 (file)
@@ -1,12 +1,18 @@
 DESCRIPTION = "File attempts to classify files depending \
 on their contents and prints a description if a match is found."
+HOMEPAGE = "http://www.darwinsys.com/file/"
 SECTION = "console/utils"
-LICENSE = "BSD-ADV"
+
+# two clause BSD
+LICENSE = "BSD"
+
 DEPENDS = "file-native"
+DEPENDS_virtclass-native = ""
 
 SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
            file://dump \
            file://filesystems"
+SRC_URI_append_virtclass-native = " file://native-fix.diff;patch=1"
 
 inherit autotools
 
@@ -16,6 +22,4 @@ do_configure_prepend() {
        cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
 }
 
-DEPENDS_virtclass-native = ""
-SRC_URI_append_virtclass-native = " file://native-fix.diff;patch=1"
 BBCLASSEXTEND = "native"